On Tue, Sep 01, 2015 at 09:41:46AM +0900, Ken-ichirou MATSUZAWA wrote: [...] > diff --git a/net/netfilter/nfnetlink_queue_ct.c b/net/netfilter/nfnetlink_queue_ct.c > index 2a30618..299b5a8 100644 > --- a/net/netfilter/nfnetlink_queue_ct.c > +++ b/net/netfilter/nfnetlink_queue_ct.c > @@ -14,6 +14,8 @@ > #include <net/netfilter/nf_conntrack.h> > #include <net/netfilter/nfnetlink_queue.h> > > +struct nfq_ct_hook __rcu *nfq_ct_hook __read_mostly; > + > struct nf_conn *nfqnl_ct_get(struct sk_buff *entskb, size_t *size, > enum ip_conntrack_info *ctinfo) > { > @@ -34,6 +36,7 @@ struct nf_conn *nfqnl_ct_get(struct sk_buff *entskb, size_t *size, > } > return ct; > } > +EXPORT_SYMBOL_GPL(nfqnl_ct_get); After this patchset these functions are not nfqueue specific anymore, so we have to place this in a single module, eg. nfnetlink_ct_glue.c (unless someone comes up with a better name...). The idea is that nfnetlink_queue and nfnetlink_log request this module to be loaded when the CONNTRACK flag is passed. The nfqnl_ prefix should be also modified, I'd suggest you use nfnl_ct_ Does this sound good to you? -- To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html