On Thu, May 28, 2015 at 10:25:10AM +0200, Bernhard Thaler wrote: > br_parse_ip_options() does not parse any IP options, it validates IP > packets as a whole and the function name is misleading. > > Rename br_parse_ip_options() to br_validate_ipv4(). > > Signed-off-by: Bernhard Thaler <bernhard.thaler@xxxxxxxx> > --- > Patch revision history: > > v5 > * rebase to current davem/net-next > > v4 > * re-post due to errors in v3 formatting introduced by my MUA > > v3 > * re-assignment of iph variable needed because pskb_may_pull() can > invalidate the network header > * same patch as v1 again > > v2 > * first patch did not contain statement removing double iph variable > assignment > > net/bridge/br_netfilter.c | 11 ++++++----- > 1 file changed, 6 insertions(+), 5 deletions(-) > > diff --git a/net/bridge/br_netfilter.c b/net/bridge/br_netfilter.c > index a43e216..f34edb6 100644 > --- a/net/bridge/br_netfilter.c > +++ b/net/bridge/br_netfilter.c > @@ -217,7 +217,7 @@ static inline void nf_bridge_pull_encap_header_rcsum(struct sk_buff *skb) > * expected format > */ > > -static int br_parse_ip_options(struct sk_buff *skb) > +static int br_validate_ipv4(struct sk_buff *skb) > { > const struct iphdr *iph; > struct net_device *dev = skb->dev; > @@ -319,7 +319,7 @@ bad: > return -1; > } > > -/* Equivalent to br_parse_ip_options for IPv6 */ > +/* Equivalent to br_validate_ipv4 for IPv6 */ > static int br_validate_ipv6(struct sk_buff *skb) Could you send me this patch in first place so you don't need to modify the IPv6 part that you just added? Thanks. -- To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html