On 04/10/2015 05:15 AM, Pablo Neira Ayuso wrote: > +another_round: > + ret = __netif_receive_skb_ingress(skb, pfmemalloc, orig_dev); > + switch (ret) { > + case NET_RX_SUCCESS: > + case NET_RX_DROP: > + break; > + case __NET_RX_ANOTHER_ROUND: > + goto another_round; > + } > rcu_read_unlock(); > + > return ret; > } > > Couldn't this just be done as a do while? It would probably be easier to read and there wouldn't be any need for the another_round label anymore. - Alex -- To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html