Re: [PATCHv2 4/4] netfilter: bridge: rename br_parse_ip_options and delete unneeded code

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Bernhard Thaler <bernhard.thaler@xxxxxxxx> wrote:
> br_parse_ip_options() does not parse any IP options, it validates IP
> packets as a whole and the function name is misleading.
> 
> Rename br_parse_ip_options() and delete unneeded double assignment
> of iph variable.
> 
> Signed-off-by: Bernhard Thaler <bernhard.thaler@xxxxxxxx>
> ---
> @@ -216,7 +216,6 @@ static int br_parse_ip_options(struct sk_buff *skb)
>  	if (!pskb_may_pull(skb, iph->ihl*4))
>  		goto inhdr_error;
>  
> -	iph = ip_hdr(skb);

pskb_may_pull() might invalidate the network header, we have to refetch
iph because of this.
--
To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Netfitler Users]     [LARTC]     [Bugtraq]     [Yosemite Forum]

  Powered by Linux