[nft PATCH 1/3] rule: rename do_command_list_cleanup() to table_cleanup()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Let's use a more generic name for this functions, since it has nothing to do
with commands.

Signed-off-by: Arturo Borrero Gonzalez <arturo.borrero.glez@xxxxxxxxx>
---
 src/rule.c |    6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/src/rule.c b/src/rule.c
index 2fe2520..ab533da 100644
--- a/src/rule.c
+++ b/src/rule.c
@@ -733,7 +733,7 @@ static int do_command_export(struct netlink_ctx *ctx, struct cmd *cmd)
 	return 0;
 }
 
-static void do_command_list_cleanup(struct table *table)
+static void table_cleanup(struct table *table)
 {
 	struct chain *chain, *nchain;
 	struct set *set, *nset;
@@ -837,10 +837,10 @@ static int do_command_list(struct netlink_ctx *ctx, struct cmd *cmd)
 	}
 
 	table_print(table);
-	do_command_list_cleanup(table);
+	table_cleanup(table);
 	return 0;
 err:
-	do_command_list_cleanup(table);
+	table_cleanup(table);
 	return -1;
 }
 
-- 
1.7.10.4

--
To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Netfitler Users]     [LARTC]     [Bugtraq]     [Yosemite Forum]

  Powered by Linux