On Wed, Sep 24, 2014 at 11:13:51AM +0200, Arturo Borrero Gonzalez wrote: > Let's factorize common code. This is also useful in follow-up patches. > > Signed-off-by: Arturo Borrero Gonzalez <arturo.borrero.glez@xxxxxxxxx> > --- > src/rule.c | 67 +++++++++++++++++++++++++++++++----------------------------- > 1 file changed, 35 insertions(+), 32 deletions(-) > > diff --git a/src/rule.c b/src/rule.c > index 2fe2520..ac72f12 100644 > --- a/src/rule.c > +++ b/src/rule.c > @@ -749,11 +749,42 @@ static void do_command_list_cleanup(struct table *table) > } > } > > +static int do_command_list_table_content(struct netlink_ctx *ctx, > + struct cmd *cmd, struct table *table) I prefer a slightly shorter name: do_list_table. do_command_list_cleanup can probably be renamed to table_cleanup since it has nothing to do with the commands. -- To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html