On Tue, Aug 26, 2014 at 04:12:22PM +0200, Arturo Borrero Gonzalez wrote: > This helper function always schedule the rule to be removed in the following > transaction. > In follow-up patches, it is interesting to handle separately the logic of rule > activation/disactivation from the transaction mechanism. > > So, this patch simply splits the original nf_tables_delrule_one() in two > functions, allowing further control. > > While at it, for the sake of homigeneize the function naming scheme, let's > rename nf_tables_delrule_one() to nft_delrule(). > > Signed-off-by: Arturo Borrero Gonzalez <arturo.borrero.glez@xxxxxxxxx> > --- > v2: no changes, resending the series. > > net/netfilter/nf_tables_api.c | 26 +++++++++++++++++++++----- > 1 file changed, 21 insertions(+), 5 deletions(-) > > diff --git a/net/netfilter/nf_tables_api.c b/net/netfilter/nf_tables_api.c > index deeb95f..d1535d8 100644 > --- a/net/netfilter/nf_tables_api.c > +++ b/net/netfilter/nf_tables_api.c > @@ -1868,12 +1868,10 @@ err1: > } > > static int > -nf_tables_delrule_one(struct nft_ctx *ctx, struct nft_rule *rule) > +nf_tables_delrule_disactivate(struct nft_ctx *ctx, struct nft_rule *rule) Without any further review so far, this grammatical error has disturbed me for a while now :) Please don't spread it further, its called deactivate. -- To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html