On Fri, Jul 25, 2014 at 01:25:35PM +0200, Daniel Borkmann wrote: > [ also Cc'ing Willem, Pablo ] > > On 07/25/2014 10:04 AM, Alexei Starovoitov wrote: > >'sk_filter' name is used as 'struct sk_filter', function sk_filter() and > >as variable 'sk_filter', which makes code hard to read. > >Also it's easily confused with 'struct sock_filter' > >Rename 'struct sk_filter' to 'struct bpf_prog' to clarify semantics and > >align the name with generic BPF use model. > > Agreed, as we went for kernel/bpf/, renaming makes absolutely sense. My nft socket filtering changes are accomodated into struct sk_filter, and will still be, so I still need some generic name there... Please, leave this as it is. > >The only ugly place is uapi/linux/netfilter/xt_bpf.h which > >managed to expose kernel internal structure into uapi header. > >Though it shouldn't even compile in user space, preserve the mess by > >adding empty 'struct sk_filter;' there and type cast it to 'struct bpf_prog' > >inside kernel in net/netfilter/xt_bpf.c > > > >Signed-off-by: Alexei Starovoitov <ast@xxxxxxxxxxxx> > >--- > > > >alternative fix for xt_bpf.h could be to replace: > > /* only used in the kernel */ > > struct sk_filter *filter __attribute__((aligned(8))); > >with > > /* only used in the kernel */ > > void *filter __attribute__((aligned(8))); > > > >but this 'void *' approach may further break broken userspace, > >whereas the fix implemented here is more seamless. > > Yep, that's not good, 'struct sk_filter' should never have been in a uapi > file actually. You can just send me a patch to change it to void. It's an internal kernel pointer as the comment states. There is **no** way that userspace can lurk with that from iptables at all. -- To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html