On 09/03/2013 04:02 PM, Eric Dumazet wrote:
On Tue, 2013-09-03 at 12:26 +0200, Daniel Borkmann wrote:
Replace these places with reciprocal_divide() inline function instead of
reimplementing it each time, thus it will become easier to read. We do not
need to explicitly include its header as it's pulled in from linux/net.h
anyway.
Sure, (((u64) hash * qcount) >> 32) happens to be
reciprocal_divide(hash, qcount) but the result depends on hash being
well distributed in [0 .. ~0U] space.
So 'reciprocal' and 'divide' do not accurately describe this exact
operation.
I suggest making the thing more descriptive.
(And discussed on lkml btw)
Sure, we can do that. Then lets drop these two for now.
--
To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html