On Tue, Mar 19, 2013 at 10:37:08AM -0400, David S. Miller wrote: > From: Jan Engelhardt <jengelh@xxxxxxx> > Date: Tue, 19 Mar 2013 15:34:56 +0100 (CET) > > > > > On Tuesday 2013-03-19 15:26, David Miller wrote: > >> > >>> + if (par->family == NFPROTO_IPV4) > >>> + queue = (((u64) hash_v4(skb) * info->queues_total) >> > >>> + 32) + queue; > >>> +#if IS_ENABLED(CONFIG_IP6_NF_IPTABLES) > >>> + else if (par->family == NFPROTO_IPV6) > >>> + queue = (((u64) hash_v6(skb) * info->queues_total) >> > >>> + 32) + queue; > >>> +#endif > >> > >>Maybe add a helper function so you don't have to indent so deeply. Something > >>like: > > > > And combined with smart arranging of clauses, won't need an extra > > helper function. > > http://www.braceless.org/Various/The%20Else%20Statement%20Considered%20Harmful > > > > Something like > > Yes, but: > > > + queue = (((u64) hash_v4(skb) * info->queues_total) >> > > + 32) + queue; > ^^^^^^ > > it's that terribly indented giblet that I want to disappear. Fully agreed, but at this time I kept the indentation. Take a look at the changes done in nfqueue_tg_v1() from patch #2. Will see how I can address your point. -- To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html