Re: [ULOGD PATCH 2/5] New MARK filtering module.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hello,

On Friday, 2008 June  6 at 15:29:49 +0200, Patrick McHardy wrote:
> Eric Leblond wrote:
>> +static struct config_keyset libulog_kset = {
>> +	.num_ces = 2,
>> +	.ces = {
>> +		{
>> +			.key 	 = "mark",
> enum foo_keys {
> 	FOO_MARK,
> 	FOO_MASK,
> 	...
> };
>
> struct config_keyset foo_kset = {
> ...
> 	.ces = {
> 		[FOO_MARK] = {
> 			...
> 		},
> 	},
> };

I like this approach. The code is far more readable.

>
> Or maybe resolve them at runtime using the key string in
> performance uncritical paths?
>

BR,
-- 
Eric Leblond
INL: http://www.inl.fr/
NuFW: http://www.nufw.org/
--
To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Netfitler Users]     [LARTC]     [Bugtraq]     [Yosemite Forum]

  Powered by Linux