Jan Engelhardt wrote:
On Oct 20 2007 17:09, Patrick McHardy wrote:
Jan Engelhardt wrote:
Give the target, match, check, etc. functions unique names.
static unsigned int
-target(struct sk_buff *skb,
- const struct net_device *in,
- const struct net_device *out,
- unsigned int hooknum,
- const struct xt_target *target,
- const void *targinfo)
+CLUSTERIP_target(struct sk_buff *skb, const struct net_device *in,
+ const struct net_device *out, unsigned int hooknum,
+ const struct xt_target *target, const void *targinfo)
{
I don't really like this naming scheme since it uses capital letters
in the function name. The _target prefix should be enough to distinguish
matches and targets, no?
Had not thought about that yet, but yes.
What about MARK_parse_v0 vs. mark_parse_v0? I did not feel like
elongating that to xt_mark_target_parse_v0 and xt_mark_match_parse_v0.
Yeah, thats not so great either. Can't think of a better scheme
right now, anyone else got some suggestions?
-
To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html