[merged] fbcon-convert-last-fbcon_takeover-call-to-do_fbcon_takeover.patch removed from -mm tree

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Subject: [merged] fbcon-convert-last-fbcon_takeover-call-to-do_fbcon_takeover.patch removed from -mm tree
To: udknight@xxxxxxxxx,FlorianSchandinat@xxxxxx,airlied@xxxxxxxx,daniel.vetter@xxxxxxxx,greg@xxxxxxxxx,huax.lu@xxxxxxxxx,jslaby@xxxxxxx,maarten.lankhorst@xxxxxxxxxxxxx,sedat.dilek@xxxxxxxxx,tiwai@xxxxxxx,tomi.valkeinen@xxxxxx,mm-commits@xxxxxxxxxxxxxxx
From: akpm@xxxxxxxxxxxxxxxxxxxx
Date: Wed, 22 May 2013 14:35:48 -0700


The patch titled
     Subject: fbcon: convert last fbcon_takeover call to do_fbcon_takeover
has been removed from the -mm tree.  Its filename was
     fbcon-convert-last-fbcon_takeover-call-to-do_fbcon_takeover.patch

This patch was dropped because it was merged into mainline or a subsystem tree

------------------------------------------------------
From: Wang YanQing <udknight@xxxxxxxxx>
Subject: fbcon: convert last fbcon_takeover call to do_fbcon_takeover

After 50e244cc7 ("fb: rework locking to fix lock ordering on takeover")
and e93a9a8687 ("fb: Yet another band-aid for fixing lockdep mess") we
have two functions implement almost the same, except the caller/callee
hold lock.

fbcon_takeover vs do_fbcon_takeover
register_con_driver vs do_register_con_driver
take_over_console vs do_take_over_console
unbind_con_driver vs do_unbind_con_driver
bind_con_driver vs do_bind_con_driver
unregister_con_driver vs do_unregister_con_driver

This issue brings us much code duplication, like do_fbcon_takeover and
fbcon_takeover, they have almost the same.

Although some of them had been re-written as a wrapper for another, but
the wrapper is so trivial, we can just throw them away.

Also those two versions of almost the same functions will confuse API's
user.

After all, I think this issue is not good for long time maintain.

This patch series converts all to the new version which caller hold the
lock, and then deletes the old version.



This patch:

After 054430e773 ("fbcon: fix locking harder"), there is only one place
use do_fbcon_takeover now, this patch convert it to do_fbcon_takeover too,
then we can delete fbcon_takeover whos function can be achieved with
do_fbcon_takeover easily to reduce code size and duplication.

Signed-off-by: Wang YanQing <udknight@xxxxxxxxx>
Cc: Greg KH <greg@xxxxxxxxx>
Cc: Jiri Slaby <jslaby@xxxxxxx>
Cc: Dave Airlie <airlied@xxxxxxxx>
Cc: Florian Tobias Schandinat <FlorianSchandinat@xxxxxx>
Cc: Tomi Valkeinen <tomi.valkeinen@xxxxxx>
Cc: Daniel Vetter <daniel.vetter@xxxxxxxx>
Cc: Sedat Dilek <sedat.dilek@xxxxxxxxx>
Cc: Maarten Lankhorst <maarten.lankhorst@xxxxxxxxxxxxx>
Cc: Lu Hua <huax.lu@xxxxxxxxx>
Cc: Takashi Iwai <tiwai@xxxxxxx>
Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx>
---

 drivers/video/console/fbcon.c |    3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff -puN drivers/video/console/fbcon.c~fbcon-convert-last-fbcon_takeover-call-to-do_fbcon_takeover drivers/video/console/fbcon.c
--- a/drivers/video/console/fbcon.c~fbcon-convert-last-fbcon_takeover-call-to-do_fbcon_takeover
+++ a/drivers/video/console/fbcon.c
@@ -3515,8 +3515,9 @@ static void fbcon_start(void)
 			}
 		}
 
+		do_fbcon_takeover(0);
 		console_unlock();
-		fbcon_takeover(0);
+
 	}
 }
 
_

Patches currently in -mm which might be from udknight@xxxxxxxxx are

linux-next.patch

--
To unsubscribe from this list: send the line "unsubscribe mm-commits" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Kernel Newbies FAQ]     [Kernel Archive]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [Bugtraq]     [Photo]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]

  Powered by Linux