The patch titled Subject: relay: use macro PAGE_ALIGN instead of FIX_SIZE has been added to the -mm tree. Its filename is relay-use-macro-page_align-instead-of-fix_size.patch Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/SubmitChecklist when testing your code *** The -mm tree is included into linux-next and is updated there every 3-4 working days ------------------------------------------------------ From: "zhangwei(Jovi)" <jovi.zhangwei@xxxxxxxxxx> Subject: relay: use macro PAGE_ALIGN instead of FIX_SIZE Macro FIX_SIZE is same as PAGE_ALIGN at present, so use PAGE_ALIGN instead. Thanks Andrew found this. Signed-off-by: zhangwei(Jovi) <jovi.zhangwei@xxxxxxxxxx> Cc: Jens Axboe <axboe@xxxxxxxxx> Cc: Al Viro <viro@xxxxxxxxxxxxxxxxxx> Cc: Eric Dumazet <edumazet@xxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- kernel/relay.c | 5 +---- 1 file changed, 1 insertion(+), 4 deletions(-) diff -puN kernel/relay.c~relay-use-macro-page_align-instead-of-fix_size kernel/relay.c --- a/kernel/relay.c~relay-use-macro-page_align-instead-of-fix_size +++ a/kernel/relay.c @@ -550,9 +550,6 @@ static int __cpuinit relay_hotcpu_callba return NOTIFY_OK; } -/* Needs a _much_ better name... */ -#define FIX_SIZE(x) ((((x) - 1) & PAGE_MASK) + PAGE_SIZE) - /** * relay_open - create a new relay channel * @base_filename: base name of files to create, %NULL for buffering only @@ -591,7 +588,7 @@ struct rchan *relay_open(const char *bas chan->version = RELAYFS_CHANNEL_VERSION; chan->n_subbufs = n_subbufs; chan->subbuf_size = subbuf_size; - chan->alloc_size = FIX_SIZE(subbuf_size * n_subbufs); + chan->alloc_size = PAGE_ALIGN(subbuf_size * n_subbufs); chan->parent = parent; chan->private_data = private_data; if (base_filename) { _ Patches currently in -mm which might be from jovi.zhangwei@xxxxxxxxxx are linux-next.patch printk-tracing-rework-console-tracing.patch relay-remove-unused-function-argument-actor.patch relay-move-fix_size-macro-into-relayc.patch relay-use-macro-page_align-instead-of-fix_size.patch -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html