The patch titled atm: use for_each_set_bit() has been removed from the -mm tree. Its filename was atm-use-for_each_set_bit.patch This patch was dropped because it was merged into mainline or a subsystem tree The current -mm tree may be found at http://userweb.kernel.org/~akpm/mmotm/ ------------------------------------------------------ Subject: atm: use for_each_set_bit() From: Akinobu Mita <akinobu.mita@xxxxxxxxx> Replace open-coded loop with for_each_set_bit(). Signed-off-by: Akinobu Mita <akinobu.mita@xxxxxxxxx> Cc: Chas Williams <chas@xxxxxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- drivers/atm/lanai.c | 7 +++---- 1 file changed, 3 insertions(+), 4 deletions(-) diff -puN drivers/atm/lanai.c~atm-use-for_each_set_bit drivers/atm/lanai.c --- a/drivers/atm/lanai.c~atm-use-for_each_set_bit +++ a/drivers/atm/lanai.c @@ -306,11 +306,10 @@ static void vci_bitfield_iterate(struct const unsigned long *lp, void (*func)(struct lanai_dev *,vci_t vci)) { - vci_t vci = find_first_bit(lp, NUM_VCI); - while (vci < NUM_VCI) { + vci_t vci; + + for_each_set_bit(vci, lp, NUM_VCI) func(lanai, vci); - vci = find_next_bit(lp, NUM_VCI, vci + 1); - } } /* -------------------- BUFFER UTILITIES: */ _ Patches currently in -mm which might be from akinobu.mita@xxxxxxxxx are origin.patch ntfs-use-bitmap_weight.patch hpet-use-for_each_set_bit.patch linux-next.patch intel-iommu-use-for_each_set_bit.patch bitops-rename-for_each_bit-to-for_each_set_bit-mtd.patch bitops-remove-temporary-for_each_bit.patch -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html