The patch titled thermal: disable polling if passive_delay and polling_delay are both unset has been added to the -mm tree. Its filename is thermal-disable-polling-if-passive_delay-and-polling_delay-are-both-unset.patch Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/SubmitChecklist when testing your code *** See http://userweb.kernel.org/~akpm/stuff/added-to-mm.txt to find out what to do about this The current -mm tree may be found at http://userweb.kernel.org/~akpm/mmotm/ ------------------------------------------------------ Subject: thermal: disable polling if passive_delay and polling_delay are both unset From: Frans Pop <elendil@xxxxxxxxx> Otherwise polling will continue for the thermal zone even when it is no longer needed, for example because forced passive cooling was disabled. Signed-off-by: Frans Pop <elendil@xxxxxxxxx> Acked-by: Matthew Garrett <mjg@xxxxxxxxxx> Cc: Zhang Rui <rui.zhang@xxxxxxxxx> Cc: Len Brown <lenb@xxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- diff -puN drivers/thermal/thermal_sys.c~thermal-disable-polling-if-passive_delay-and-polling_delay-are-both-unset drivers/thermal/thermal_sys.c --- a/drivers/thermal/thermal_sys.c~thermal-disable-polling-if-passive_delay-and-polling_delay-are-both-unset +++ a/drivers/thermal/thermal_sys.c @@ -1019,6 +1019,8 @@ void thermal_zone_device_update(struct t thermal_zone_device_set_polling(tz, tz->passive_delay); else if (tz->polling_delay) thermal_zone_device_set_polling(tz, tz->polling_delay); + else + thermal_zone_device_set_polling(tz, 0); mutex_unlock(&tz->lock); } EXPORT_SYMBOL(thermal_zone_device_update); _ Patches currently in -mm which might be from elendil@xxxxxxxxx are linux-next.patch thermal-sysfs-apitxt-reformat-for-improved-readability.patch thermal-sysfs-apitxt-document-passive-attribute-for-thermal-zones.patch acpi-thermal-display-forced-passive-trip-points-in-proc.patch thermal-add-sanity-check-for-the-passive-attribute.patch thermal-only-set-passive_delay-for-forced_passive-cooling.patch thermal-disable-polling-if-passive_delay-and-polling_delay-are-both-unset.patch -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html