The patch titled hci_usb: remove code obfuscation has been added to the -mm tree. Its filename is hci_usb-remove-code-obfuscation.patch Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/SubmitChecklist when testing your code *** See http://www.zip.com.au/~akpm/linux/patches/stuff/added-to-mm.txt to find out what to do about this The current -mm tree may be found at http://userweb.kernel.org/~akpm/mmotm/ ------------------------------------------------------ Subject: hci_usb: remove code obfuscation From: Pavel Machek <pavel@xxxxxx> _urb_free is an alias for kfree... making code longer & harder to read. Remove it. Signed-off-by: Pavel Machek <pavel@xxxxxxx> Cc: Marcel Holtmann <marcel@xxxxxxxxxxxx> Cc: Dave Young <hidave.darkstar@xxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- drivers/bluetooth/hci_usb.c | 10 +++++----- drivers/bluetooth/hci_usb.h | 5 ----- 2 files changed, 5 insertions(+), 10 deletions(-) diff -puN drivers/bluetooth/hci_usb.c~hci_usb-remove-code-obfuscation drivers/bluetooth/hci_usb.c --- a/drivers/bluetooth/hci_usb.c~hci_usb-remove-code-obfuscation +++ a/drivers/bluetooth/hci_usb.c @@ -265,7 +265,7 @@ static int hci_usb_intr_rx_submit(struct BT_ERR("%s intr rx submit failed urb %p err %d", husb->hdev->name, urb, err); _urb_unlink(_urb); - _urb_free(_urb); + kfree(_urb); kfree(buf); } return err; @@ -302,7 +302,7 @@ static int hci_usb_bulk_rx_submit(struct BT_ERR("%s bulk rx submit failed urb %p err %d", husb->hdev->name, urb, err); _urb_unlink(_urb); - _urb_free(_urb); + kfree(_urb); kfree(buf); } return err; @@ -353,7 +353,7 @@ static int hci_usb_isoc_rx_submit(struct BT_ERR("%s isoc rx submit failed urb %p err %d", husb->hdev->name, urb, err); _urb_unlink(_urb); - _urb_free(_urb); + kfree(_urb); kfree(buf); } return err; @@ -431,7 +431,7 @@ static void hci_usb_unlink_urbs(struct h husb->hdev->name, _urb, _urb->type, urb); kfree(urb->setup_packet); kfree(urb->transfer_buffer); - _urb_free(_urb); + kfree(_urb); } } } @@ -490,7 +490,7 @@ static inline int hci_usb_send_ctrl(stru dr = kmalloc(sizeof(*dr), GFP_ATOMIC); if (!dr) { - _urb_free(_urb); + kfree(_urb); return -ENOMEM; } } else diff -puN drivers/bluetooth/hci_usb.h~hci_usb-remove-code-obfuscation drivers/bluetooth/hci_usb.h --- a/drivers/bluetooth/hci_usb.h~hci_usb-remove-code-obfuscation +++ a/drivers/bluetooth/hci_usb.h @@ -60,11 +60,6 @@ struct _urb { struct urb urb; }; -static inline void _urb_free(struct _urb *_urb) -{ - kfree(_urb); -} - static inline void _urb_queue_init(struct _urb_queue *q) { INIT_LIST_HEAD(&q->head); _ Patches currently in -mm which might be from pavel@xxxxxx are git-x86.patch git-acpi.patch pm-remove-destroy_suspended_device.patch git-hrt.patch hci_usb-do-not-initialize-static-variables-to-0.patch hci_usb-remove-code-obfuscation.patch hci_usbh-fix-hard-to-trigger-race.patch pm-gxfb-add-hook-to-pm-console-layer-that-allows-disabling-of-suspend-vt-switch.patch pm-gxfb-add-hook-to-pm-console-layer-that-allows-disabling-of-suspend-vt-switch-fix.patch -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html