The patch titled eCryptfs: replace magic numbers has been removed from the -mm tree. Its filename was ecryptfs-replace-magic-numbers.patch This patch was dropped because it was merged into mainline or a subsystem tree ------------------------------------------------------ Subject: eCryptfs: replace magic numbers From: Michael Halcrow <mhalcrow@xxxxxxxxxx> Replace some magic numbers with sizeof() equivalents. Signed-off-by: Michael Halcrow <mhalcrow@xxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- fs/ecryptfs/crypto.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff -puN fs/ecryptfs/crypto.c~ecryptfs-replace-magic-numbers fs/ecryptfs/crypto.c --- a/fs/ecryptfs/crypto.c~ecryptfs-replace-magic-numbers +++ a/fs/ecryptfs/crypto.c @@ -1426,10 +1426,10 @@ static int parse_header_metadata(struct u32 header_extent_size; u16 num_header_extents_at_front; - memcpy(&header_extent_size, virt, 4); + memcpy(&header_extent_size, virt, sizeof(u32)); header_extent_size = be32_to_cpu(header_extent_size); - virt += 4; - memcpy(&num_header_extents_at_front, virt, 2); + virt += sizeof(u32); + memcpy(&num_header_extents_at_front, virt, sizeof(u16)); num_header_extents_at_front = be16_to_cpu(num_header_extents_at_front); crypt_stat->num_header_extents_at_front = (int)num_header_extents_at_front; _ Patches currently in -mm which might be from mhalcrow@xxxxxxxxxx are origin.patch git-unionfs.patch ecryptfs-allow-lower-fs-to-interpret-attr_kill_sid.patch vfs-make-notify_change-pass-attr_kill_sid-to-setattr-operations.patch - To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html