The patch titled rename cancel_rearming_delayed_work() to cancel_delayed_work_sync() has been added to the -mm tree. Its filename is rename-cancel_rearming_delayed_work-to-cancel_delayed_work_sync.patch *** Remember to use Documentation/SubmitChecklist when testing your code *** See http://www.zip.com.au/~akpm/linux/patches/stuff/added-to-mm.txt to find out what to do about this ------------------------------------------------------ Subject: rename cancel_rearming_delayed_work() to cancel_delayed_work_sync() From: Oleg Nesterov <oleg@xxxxxxxxxx> Imho, the current naming of cancel_xxx workqueue functions is very confusing. cancel_delayed_work() cancel_rearming_delayed_work() cancel_rearming_delayed_workqueue() // obsolete cancel_work_sync() This looks as if the first 2 functions differ in "type" of their argument which is not true any longer, nowadays the difference is the behaviour. The semantics of cancel_rearming_delayed_work(dwork) was changed significantly, it doesn't require that dwork rearms itself, and cancels dwork synchronously. Rename it to cancel_delayed_work_sync(). This matches cancel_delayed_work() and cancel_work_sync(). Re-create cancel_rearming_delayed_work() as a simple inline obsolete wrapper, like cancel_rearming_delayed_workqueue(). Signed-off-by: Oleg Nesterov <oleg@xxxxxxxxxx> Acked-by: Jarek Poplawski <jarkao2@xxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- include/linux/workqueue.h | 13 ++++++++++--- kernel/workqueue.c | 6 +++--- 2 files changed, 13 insertions(+), 6 deletions(-) diff -puN include/linux/workqueue.h~rename-cancel_rearming_delayed_work-to-cancel_delayed_work_sync include/linux/workqueue.h --- a/include/linux/workqueue.h~rename-cancel_rearming_delayed_work-to-cancel_delayed_work_sync +++ a/include/linux/workqueue.h @@ -166,14 +166,21 @@ static inline int cancel_delayed_work(st return ret; } -extern void cancel_rearming_delayed_work(struct delayed_work *work); +extern void cancel_delayed_work_sync(struct delayed_work *work); -/* Obsolete. use cancel_rearming_delayed_work() */ +/* Obsolete. use cancel_delayed_work_sync() */ static inline void cancel_rearming_delayed_workqueue(struct workqueue_struct *wq, struct delayed_work *work) { - cancel_rearming_delayed_work(work); + cancel_delayed_work_sync(work); +} + +/* Obsolete. use cancel_delayed_work_sync() */ +static inline +void cancel_rearming_delayed_work(struct delayed_work *work) +{ + cancel_delayed_work_sync(work); } #endif diff -puN kernel/workqueue.c~rename-cancel_rearming_delayed_work-to-cancel_delayed_work_sync kernel/workqueue.c --- a/kernel/workqueue.c~rename-cancel_rearming_delayed_work-to-cancel_delayed_work_sync +++ a/kernel/workqueue.c @@ -486,13 +486,13 @@ void cancel_work_sync(struct work_struct EXPORT_SYMBOL_GPL(cancel_work_sync); /** - * cancel_rearming_delayed_work - reliably kill off a delayed work. + * cancel_delayed_work_sync - reliably kill off a delayed work. * @dwork: the delayed work struct * * It is possible to use this function if @dwork rearms itself via queue_work() * or queue_delayed_work(). See also the comment for cancel_work_sync(). */ -void cancel_rearming_delayed_work(struct delayed_work *dwork) +void cancel_delayed_work_sync(struct delayed_work *dwork) { while (!del_timer(&dwork->timer) && !try_to_grab_pending(&dwork->work)) @@ -500,7 +500,7 @@ void cancel_rearming_delayed_work(struct wait_on_work(&dwork->work); work_clear_pending(&dwork->work); } -EXPORT_SYMBOL(cancel_rearming_delayed_work); +EXPORT_SYMBOL(cancel_delayed_work_sync); static struct workqueue_struct *keventd_wq __read_mostly; _ Patches currently in -mm which might be from oleg@xxxxxxxxxx are libata-core-convert-to-use-cancel_rearming_delayed_work.patch freezer-make-kernel-threads-nonfreezable-by-default.patch freezer-make-kernel-threads-nonfreezable-by-default-fix.patch freezer-make-kernel-threads-nonfreezable-by-default-fix-fix.patch freezer-make-kernel-threads-nonfreezable-by-default-fix-2.patch freezer-run-show_state-when-freezing-times-out.patch hibernation-prepare-to-enter-the-low-power-state.patch freezer-avoid-freezing-kernel-threads-prematurely.patch freezer-use-__set_current_state-in-refrigerator.patch freezer-return-int-from-freeze_processes.patch freezer-remove-redundant-check-in-try_to_freeze_tasks.patch pm-prevent-frozen-user-mode-helpers-from-failing-the-freezing-of-tasks-rev-2.patch add-generic-exit-time-stack-depth-checking-to-config_debug_stack_usage.patch clone-flag-clone_parent_tidptr-leaves-invalid-results-in-memory.patch use-write_trylock_irqsave-in-ptrace_attach.patch fix-stop_machine_run-problem-with-naughty-real-time-process.patch cpu-hotplug-fix-ksoftirqd-termination-on-cpu-hotplug-with-naughty-realtime-process.patch cpu-hotplug-fix-ksoftirqd-termination-on-cpu-hotplug-with-naughty-realtime-process-fix.patch percpu_counters-use-cpu-notifiers.patch percpu_counters-use-for_each_online_cpu.patch mm-fix-create_new_namespaces-return-value.patch adb_probe_task-remove-unneeded-flush_signals-call.patch kcdrwd-remove-unneeded-flush_signals-call.patch nbdcsock_xmit-cleanup-signal-related-code.patch rename-cancel_rearming_delayed_work-to-cancel_delayed_work_sync.patch make-cancel_xxx_work_sync-return-a-boolean.patch - To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html