The patch titled Subject: mm/page_alloc: replace flag check with PageHWPoison() in check_new_page_bad() has been added to the -mm mm-unstable branch. Its filename is mm-page_alloc-replace-flag-check-with-pagehwpoison-in-check_new_page_bad.patch This patch will shortly appear at https://git.kernel.org/pub/scm/linux/kernel/git/akpm/25-new.git/tree/patches/mm-page_alloc-replace-flag-check-with-pagehwpoison-in-check_new_page_bad.patch This patch will later appear in the mm-unstable branch at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next via the mm-everything branch at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm and is updated there every 2-3 working days ------------------------------------------------------ From: Ye Liu <liuye@xxxxxxxxxx> Subject: mm/page_alloc: replace flag check with PageHWPoison() in check_new_page_bad() Date: Thu, 20 Mar 2025 14:33:46 +0800 This patch replaces the direct check for the __PG_HWPOISON flag with the PageHWPoison() macro, improving code readability and maintaining consistency with other parts of the memory management code. Link: https://lkml.kernel.org/r/20250320063346.489030-1-ye.liu@xxxxxxxxx Signed-off-by: Ye Liu <liuye@xxxxxxxxxx> Reviewed-by: Sidhartha Kumar <sidhartha.kumar@xxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/page_alloc.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) --- a/mm/page_alloc.c~mm-page_alloc-replace-flag-check-with-pagehwpoison-in-check_new_page_bad +++ a/mm/page_alloc.c @@ -1559,7 +1559,7 @@ static __always_inline void page_del_and static void check_new_page_bad(struct page *page) { - if (unlikely(page->flags & __PG_HWPOISON)) { + if (unlikely(PageHWPoison(page))) { /* Don't complain about hwpoisoned pages */ if (PageBuddy(page)) __ClearPageBuddy(page); _ Patches currently in -mm which might be from liuye@xxxxxxxxxx are mm-page_alloc-remove-unnecessary-__maybe_unused-in-order_to_pindex.patch mm-page_alloc-replace-flag-check-with-pagehwpoison-in-check_new_page_bad.patch