The quilt patch titled Subject: mm/swapfile.c: update the code comment above swap_count_continued() has been removed from the -mm tree. Its filename was mm-swapfilec-update-the-code-comment-above-swap_count_continued-v2.patch This patch was dropped because it was folded into mm-swapfilec-update-the-code-comment-above-swap_count_continued.patch ------------------------------------------------------ From: Baoquan He <bhe@xxxxxxxxxx> Subject: mm/swapfile.c: update the code comment above swap_count_continued() Date: Fri, 7 Feb 2025 10:50:37 +0800 Now, swap_count_continued() has two callers, __swap_duplicate() and __swap_entry_free_locked(), the relevant code comment is stale. Update it to reflect the current situation. Link: https://lkml.kernel.org/r/Z6V0/UvG1fvkQ4t/@fedora Signed-off-by: Baoquan He <bhe@xxxxxxxxxx> Cc: Chris Li <chrisl@xxxxxxxxxx> Cc: Kairui Song <ryncsn@xxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/swapfile.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) --- a/mm/swapfile.c~mm-swapfilec-update-the-code-comment-above-swap_count_continued-v2 +++ a/mm/swapfile.c @@ -3798,7 +3798,7 @@ outer: * when the original swap_map count is decremented from 0 with continuation, * borrow from the continuation and report whether it still holds more. * Called while __swap_duplicate() or caller of __swap_entry_free_locked() - * holds swap or cluster lock. + * holds cluster lock. */ static bool swap_count_continued(struct swap_info_struct *si, pgoff_t offset, unsigned char count) _ Patches currently in -mm which might be from bhe@xxxxxxxxxx are mm-swap_statec-fix-the-obsolete-code-comment.patch mm-swap_statec-optimize-the-code-in-clear_shadow_from_swap_cache.patch mm-swap-remove-swap_flag_prio_shift.patch mm-swap-skip-scanning-cluster-range-if-its-empty-cluster.patch mm-swap-rename-swap_is_has_cache-to-swap_only_has_cache.patch mm-swapfilec-update-the-code-comment-above-swap_count_continued.patch mm-swapfilec-optimize-code-in-setup_clusters.patch mm-swap_statec-remove-the-meaningless-code-comment.patch mm-swapfilec-remove-the-unneeded-checking.patch mm-swap-rename-swap_swapcount-to-swap_entry_swapped.patch mm-swapfilec-remove-the-incorrect-code-comment.patch mm-swapfilec-open-code-cluster_alloc_swap.patch mm-mmu_gather-remove-unused-__tlb_remove_page.patch mm-mmu_gather-clean-up-the-stale-code-comment.patch