The patch titled Subject: mm/shrinker: fix name consistency issue in shrinker_debugfs_rename() has been added to the -mm mm-unstable branch. Its filename is mm-shrinker-fix-name-consistency-issue-in-shrinker_debugfs_rename.patch This patch will shortly appear at https://git.kernel.org/pub/scm/linux/kernel/git/akpm/25-new.git/tree/patches/mm-shrinker-fix-name-consistency-issue-in-shrinker_debugfs_rename.patch This patch will later appear in the mm-unstable branch at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next via the mm-everything branch at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm and is updated there every 2-3 working days ------------------------------------------------------ From: Liu Ye <liuye@xxxxxxxxxx> Subject: mm/shrinker: fix name consistency issue in shrinker_debugfs_rename() Date: Wed, 5 Mar 2025 15:17:59 +0800 After calling debugfs_change_name function, the return value should be checked and the old name restored. If debugfs_change_name fails, the new name memory should be freed. The effect is that the shrinker->name is not consistent with the name displayed in debugfs. Link: https://lkml.kernel.org/r/20250305071759.661055-1-liuye@xxxxxxxxxx Signed-off-by: Liu Ye <liuye@xxxxxxxxxx> Reviewed-by: Muchun Song <muchun.song@xxxxxxxxx> Reviewed-byï¼?Qi Zheng <zhengqi.arch@xxxxxxxxxxxx Reviewed-by: Roman Gushchin <roman.gushchin@xxxxxxxxx> Cc: Dave Chinner <david@xxxxxxxxxxxxx> Cc: Muchun Song <muchun.song@xxxxxxxxx> Cc: Qi Zheng <zhengqi.arch@xxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/shrinker_debug.c | 8 ++++++-- 1 file changed, 6 insertions(+), 2 deletions(-) --- a/mm/shrinker_debug.c~mm-shrinker-fix-name-consistency-issue-in-shrinker_debugfs_rename +++ a/mm/shrinker_debug.c @@ -214,10 +214,14 @@ int shrinker_debugfs_rename(struct shrin ret = debugfs_change_name(shrinker->debugfs_entry, "%s-%d", shrinker->name, shrinker->debugfs_id); + if (ret) { + shrinker->name = old; + kfree_const(new); + } else { + kfree_const(old); + } mutex_unlock(&shrinker_mutex); - kfree_const(old); - return ret; } EXPORT_SYMBOL(shrinker_debugfs_rename); _ Patches currently in -mm which might be from liuye@xxxxxxxxxx are mm-memfd-fix-spelling-and-grammatical-issues.patch mm-folio_queue-delete-__folio_order-and-use-folio_order-directly.patch mm-vmalloc-move-free_vm_areaarea-from-the-__vmalloc_area_node-function-to-the-__vmalloc_node_range_noprof-function.patch mm-shrinker-fix-name-consistency-issue-in-shrinker_debugfs_rename.patch