The patch titled Subject: mm/mmu_gather: clean up the stale code comment has been added to the -mm mm-unstable branch. Its filename is mm-mmu_gather-clean-up-the-stale-code-comment.patch This patch will shortly appear at https://git.kernel.org/pub/scm/linux/kernel/git/akpm/25-new.git/tree/patches/mm-mmu_gather-clean-up-the-stale-code-comment.patch This patch will later appear in the mm-unstable branch at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next via the mm-everything branch at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm and is updated there every 2-3 working days ------------------------------------------------------ From: Baoquan He <bhe@xxxxxxxxxx> Subject: mm/mmu_gather: clean up the stale code comment Date: Tue, 11 Feb 2025 11:43:48 +0800 In commit d7f861b9c43a ("mm/mmu_gather: add __tlb_remove_folio_pages()"), helper function __tlb_remove_folio_pages_size() was added. And based on the helper, wrapper functions __tlb_remove_folio_pages() and __tlb_remove_page_size() are created and used by upper level functions. So let's update the code comment to reflect the current code about tlb_remove_page()/tlb_remove_page_size(), etc. Link: https://lkml.kernel.org/r/20250211034348.39531-2-bhe@xxxxxxxxxx Signed-off-by: Baoquan He <bhe@xxxxxxxxxx> Cc: "Aneesh Kumar K.V" <aneesh.kumar@xxxxxxxxxx> Cc: Nicholas Piggin <npiggin@xxxxxxxxx> Cc: Peter Zijlstra (Intel) <peterz@xxxxxxxxxxxxx> Cc: Qi Zheng <zhengqi.arch@xxxxxxxxxxxxx> Cc: Will Deacon <will@xxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- include/asm-generic/tlb.h | 23 +++++++++++------------ 1 file changed, 11 insertions(+), 12 deletions(-) --- a/include/asm-generic/tlb.h~mm-mmu_gather-clean-up-the-stale-code-comment +++ a/include/asm-generic/tlb.h @@ -72,22 +72,21 @@ * * See also MMU_GATHER_TABLE_FREE and MMU_GATHER_RCU_TABLE_FREE. * - * - tlb_remove_page() / __tlb_remove_page() - * - tlb_remove_page_size() / __tlb_remove_page_size() - * - __tlb_remove_folio_pages() - * - * __tlb_remove_page_size() is the basic primitive that queues a page for - * freeing. __tlb_remove_page() assumes PAGE_SIZE. Both will return a - * boolean indicating if the queue is (now) full and a call to - * tlb_flush_mmu() is required. + * - tlb_remove_page() / tlb_remove_page_size() + * - __tlb_remove_folio_pages() / __tlb_remove_page_size() + * - __tlb_remove_folio_pages_size() + * + * __tlb_remove_folio_pages_size() is the basic primitive that queues pages + * for freeing. It will return a boolean indicating if the queue is (now) + * full and a call to tlb_flush_mmu() is required. * * tlb_remove_page() and tlb_remove_page_size() imply the call to * tlb_flush_mmu() when required and has no return value. * - * __tlb_remove_folio_pages() is similar to __tlb_remove_page(), however, - * instead of removing a single page, remove the given number of consecutive - * pages that are all part of the same (large) folio: just like calling - * __tlb_remove_page() on each page individually. + * __tlb_remove_folio_pages() is similar to __tlb_remove_page_size(), + * however, instead of removing a single page, assume PAGE_SIZE and remove + * the given number of consecutive pages that are all part of the + * same (large) folio. * * - tlb_change_page_size() * _ Patches currently in -mm which might be from bhe@xxxxxxxxxx are mm-swap_statec-fix-the-obsolete-code-comment.patch mm-swap_statec-optimize-the-code-in-clear_shadow_from_swap_cache.patch mm-swap-remove-swap_flag_prio_shift.patch mm-swap-skip-scanning-cluster-range-if-its-empty-cluster.patch mm-swap-rename-swap_is_has_cache-to-swap_only_has_cache.patch mm-swapfilec-update-the-code-comment-above-swap_count_continued.patch mm-swapfilec-update-the-code-comment-above-swap_count_continued-v2.patch mm-swapfilec-optimize-code-in-setup_clusters.patch mm-swap_statec-remove-the-meaningless-code-comment.patch mm-swapfilec-remove-the-unneeded-checking.patch mm-swap-rename-swap_swapcount-to-swap_entry_swapped.patch mm-swapfilec-remove-the-incorrect-code-comment.patch mm-swapfilec-open-code-cluster_alloc_swap.patch mm-mmu_gather-remove-unused-__tlb_remove_page.patch mm-mmu_gather-clean-up-the-stale-code-comment.patch