The patch titled Subject: mm/swapfile.c: remove the incorrect code comment has been added to the -mm mm-unstable branch. Its filename is mm-swapfilec-remove-the-incorrect-code-comment.patch This patch will shortly appear at https://git.kernel.org/pub/scm/linux/kernel/git/akpm/25-new.git/tree/patches/mm-swapfilec-remove-the-incorrect-code-comment.patch This patch will later appear in the mm-unstable branch at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next via the mm-everything branch at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm and is updated there every 2-3 working days ------------------------------------------------------ From: Baoquan He <bhe@xxxxxxxxxx> Subject: mm/swapfile.c: remove the incorrect code comment Date: Wed, 5 Feb 2025 17:27:20 +0800 Since commit eb085574a752 ("mm, swap: fix race between swapoff and some swap operations"), the non_swap_entry() checking has been taken off from function __swap_duplicate(). Hence, in the kernel-doc comment, the line 'swp_entry is migration entry -> EINVAL' is obsolete. Remove that line to avoid misleading people. Link: https://lkml.kernel.org/r/20250205092721.9395-12-bhe@xxxxxxxxxx Signed-off-by: Baoquan He <bhe@xxxxxxxxxx> Cc: Chis Li <chrisl@xxxxxxxxxx> Cc: Kairui Song <ryncsn@xxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/swapfile.c | 1 - 1 file changed, 1 deletion(-) --- a/mm/swapfile.c~mm-swapfilec-remove-the-incorrect-code-comment +++ a/mm/swapfile.c @@ -3525,7 +3525,6 @@ void si_swapinfo(struct sysinfo *val) * Returns error code in following case. * - success -> 0 * - swp_entry is invalid -> EINVAL - * - swp_entry is migration entry -> EINVAL * - swap-cache reference is requested but there is already one. -> EEXIST * - swap-cache reference is requested but the entry is not used. -> ENOENT * - swap-mapped reference requested but needs continued swap count. -> ENOMEM _ Patches currently in -mm which might be from bhe@xxxxxxxxxx are mm-swap_statec-fix-the-obsolete-code-comment.patch mm-swap_statec-optimize-the-code-in-clear_shadow_from_swap_cache.patch mm-swap-remove-swap_flag_prio_shift.patch mm-swap-skip-scanning-cluster-range-if-its-empty-cluster.patch mm-swap-rename-swap_is_has_cache-to-swap_only_has_cache.patch mm-swapfilec-update-the-code-comment-above-swap_count_continued.patch mm-swapfilec-optimize-code-in-setup_clusters.patch mm-swap_statec-remove-the-meaningless-code-comment.patch mm-swapfilec-remove-the-unneeded-checking.patch mm-swap-rename-swap_swapcount-to-swap_entry_swapped.patch mm-swapfilec-remove-the-incorrect-code-comment.patch mm-swapfilec-open-code-cluster_alloc_swap.patch