The patch titled Subject: mm/swap: skip scanning cluster range if it's empty cluster has been added to the -mm mm-unstable branch. Its filename is mm-swap-skip-scanning-cluster-range-if-its-empty-cluster.patch This patch will shortly appear at https://git.kernel.org/pub/scm/linux/kernel/git/akpm/25-new.git/tree/patches/mm-swap-skip-scanning-cluster-range-if-its-empty-cluster.patch This patch will later appear in the mm-unstable branch at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next via the mm-everything branch at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm and is updated there every 2-3 working days ------------------------------------------------------ From: Baoquan He <bhe@xxxxxxxxxx> Subject: mm/swap: skip scanning cluster range if it's empty cluster Date: Wed, 5 Feb 2025 17:27:13 +0800 Since ci->lock has been taken when isolating cluster from si->free_clusters or taking si->percpu_cluster->next[order], it's unnecessary to scan and check the cluster range availability if i'ts empty cluster, and this can accelerate the huge page swapping. Link: https://lkml.kernel.org/r/20250205092721.9395-5-bhe@xxxxxxxxxx Signed-off-by: Baoquan He <bhe@xxxxxxxxxx> Cc: Chis Li <chrisl@xxxxxxxxxx> Cc: Kairui Song <ryncsn@xxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/swapfile.c | 3 +++ 1 file changed, 3 insertions(+) --- a/mm/swapfile.c~mm-swap-skip-scanning-cluster-range-if-its-empty-cluster +++ a/mm/swapfile.c @@ -729,6 +729,9 @@ static bool cluster_scan_range(struct sw unsigned long offset, end = start + nr_pages; unsigned char *map = si->swap_map; + if (cluster_is_empty(ci)) + return true; + for (offset = start; offset < end; offset++) { switch (READ_ONCE(map[offset])) { case 0: _ Patches currently in -mm which might be from bhe@xxxxxxxxxx are mm-swap_statec-fix-the-obsolete-code-comment.patch mm-swap_statec-optimize-the-code-in-clear_shadow_from_swap_cache.patch mm-swap-remove-swap_flag_prio_shift.patch mm-swap-skip-scanning-cluster-range-if-its-empty-cluster.patch mm-swap-rename-swap_is_has_cache-to-swap_only_has_cache.patch mm-swapfilec-update-the-code-comment-above-swap_count_continued.patch mm-swapfilec-optimize-code-in-setup_clusters.patch mm-swap_statec-remove-the-meaningless-code-comment.patch mm-swapfilec-remove-the-unneeded-checking.patch mm-swap-rename-swap_swapcount-to-swap_entry_swapped.patch mm-swapfilec-remove-the-incorrect-code-comment.patch mm-swapfilec-open-code-cluster_alloc_swap.patch