The quilt patch titled Subject: mm: also update the doc for __GFP_NOFAIL with order > 1 has been removed from the -mm tree. Its filename was mm-warn-about-illegal-__gfp_nofail-usage-in-a-more-appropriate-location-and-manner-fix.patch This patch was dropped because it was folded into mm-warn-about-illegal-__gfp_nofail-usage-in-a-more-appropriate-location-and-manner.patch ------------------------------------------------------ From: Barry Song <v-songbaohua@xxxxxxxx> Subject: mm: also update the doc for __GFP_NOFAIL with order > 1 Date: Wed, 4 Sep 2024 10:26:19 +1200 Obviously we only support order <= 1 __GFP_NOFAIL allocation and if someone wants larger memory, they should consider using kvmalloc() instead. Link: https://lkml.kernel.org/r/20240903223935.1697-1-21cnbao@xxxxxxxxx Signed-off-by: Barry Song <v-songbaohua@xxxxxxxx> Suggested-by: David Hildenbrand <david@xxxxxxxxxx> Suggested-by: Michal Hocko <mhocko@xxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- include/linux/gfp_types.h | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) --- a/include/linux/gfp_types.h~mm-warn-about-illegal-__gfp_nofail-usage-in-a-more-appropriate-location-and-manner-fix +++ a/include/linux/gfp_types.h @@ -253,7 +253,8 @@ enum { * used only when there is no reasonable failure policy) but it is * definitely preferable to use the flag rather than opencode endless * loop around allocator. - * Using this flag for costly allocations is _highly_ discouraged. + * Allocating pages from the buddy with __GFP_NOFAIL and order > 1 is + * not supported. Please consider using kvmalloc() instead. */ #define __GFP_IO ((__force gfp_t)___GFP_IO) #define __GFP_FS ((__force gfp_t)___GFP_FS) _ Patches currently in -mm which might be from v-songbaohua@xxxxxxxx are mm-count-the-number-of-anonymous-thps-per-size.patch mm-count-the-number-of-partially-mapped-anonymous-thps-per-size.patch mm-document-__gfp_nofail-must-be-blockable.patch mm-warn-about-illegal-__gfp_nofail-usage-in-a-more-appropriate-location-and-manner.patch