The patch titled Subject: mm/ksm: rename variable mm_slot to ksm_slot in unmerge_and_remove_all_rmap_items has been added to the -mm mm-unstable branch. Its filename is mm-ksm-rename-variable-mm_slot-to-ksm_slot-in-unmerge_and_remove_all_rmap_items.patch This patch will shortly appear at https://git.kernel.org/pub/scm/linux/kernel/git/akpm/25-new.git/tree/patches/mm-ksm-rename-variable-mm_slot-to-ksm_slot-in-unmerge_and_remove_all_rmap_items.patch This patch will later appear in the mm-unstable branch at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next via the mm-everything branch at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm and is updated there every 2-3 working days ------------------------------------------------------ From: "Alex Shi (tencent)" <alexs@xxxxxxxxxx> Subject: mm/ksm: rename variable mm_slot to ksm_slot in unmerge_and_remove_all_rmap_items Date: Sun, 28 Apr 2024 18:06:16 +0800 To distinguish ksm_mm_slot and mm_slot for better code readability, rename ksm_mm_slot variable as ksm_slot in function unmerge_and_remove_all_rmap_items. No function changes. Link: https://lkml.kernel.org/r/20240428100619.3332036-2-alexs@xxxxxxxxxx Signed-off-by: Alex Shi (tencent) <alexs@xxxxxxxxxx> Cc: David Hildenbrand <david@xxxxxxxxxx> Cc: Izik Eidus <izik.eidus@xxxxxxxxxxxxxxxxxx> Cc: Matthew Wilcox (Oracle) <willy@xxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/ksm.c | 20 ++++++++++---------- 1 file changed, 10 insertions(+), 10 deletions(-) --- a/mm/ksm.c~mm-ksm-rename-variable-mm_slot-to-ksm_slot-in-unmerge_and_remove_all_rmap_items +++ a/mm/ksm.c @@ -1196,7 +1196,7 @@ static int remove_all_stable_nodes(void) static int unmerge_and_remove_all_rmap_items(void) { - struct ksm_mm_slot *mm_slot; + struct ksm_mm_slot *ksm_slot; struct mm_slot *slot; struct mm_struct *mm; struct vm_area_struct *vma; @@ -1208,11 +1208,11 @@ static int unmerge_and_remove_all_rmap_i ksm_scan.ksm_slot = mm_slot_entry(slot, struct ksm_mm_slot, slot); spin_unlock(&ksm_mmlist_lock); - for (mm_slot = ksm_scan.ksm_slot; mm_slot != &ksm_mm_head; - mm_slot = ksm_scan.ksm_slot) { - VMA_ITERATOR(vmi, mm_slot->slot.mm, 0); + for (ksm_slot = ksm_scan.ksm_slot; ksm_slot != &ksm_mm_head; + ksm_slot = ksm_scan.ksm_slot) { + VMA_ITERATOR(vmi, ksm_slot->slot.mm, 0); - mm = mm_slot->slot.mm; + mm = ksm_slot->slot.mm; mmap_read_lock(mm); /* @@ -1232,19 +1232,19 @@ static int unmerge_and_remove_all_rmap_i } mm_exiting: - remove_trailing_rmap_items(&mm_slot->rmap_list); + remove_trailing_rmap_items(&ksm_slot->rmap_list); mmap_read_unlock(mm); spin_lock(&ksm_mmlist_lock); - slot = list_entry(mm_slot->slot.mm_node.next, + slot = list_entry(ksm_slot->slot.mm_node.next, struct mm_slot, mm_node); ksm_scan.ksm_slot = mm_slot_entry(slot, struct ksm_mm_slot, slot); if (ksm_test_exit(mm)) { - hash_del(&mm_slot->slot.hash); - list_del(&mm_slot->slot.mm_node); + hash_del(&ksm_slot->slot.hash); + list_del(&ksm_slot->slot.mm_node); spin_unlock(&ksm_mmlist_lock); - mm_slot_free(mm_slot_cache, mm_slot); + mm_slot_free(mm_slot_cache, ksm_slot); clear_bit(MMF_VM_MERGEABLE, &mm->flags); clear_bit(MMF_VM_MERGE_ANY, &mm->flags); mmdrop(mm); _ Patches currently in -mm which might be from alexs@xxxxxxxxxx are mm-ksm-add-ksm_get_folio.patch mm-ksm-use-folio-in-remove_rmap_item_from_tree.patch mm-ksm-add-folio_set_stable_node.patch mm-ksm-use-folio-in-remove_stable_node.patch mm-ksm-use-folio-in-stable_node_dup.patch mm-ksm-use-ksm_get_folio-in-scan_get_next_rmap_item.patch mm-ksm-use-folio-in-write_protect_page.patch mm-ksm-convert-chain-series-funcs-and-replace-get_ksm_page.patch mm-ksm-replace-set_page_stable_node-by-folio_set_stable_node.patch mm-ksm-rename-mm_slot-members-to-ksm_slot-for-better-readability.patch mm-ksm-rename-variable-mm_slot-to-ksm_slot-in-unmerge_and_remove_all_rmap_items.patch mm-ksm-rename-mm_slot_cache-to-ksm_slot_cache.patch mm-ksm-rename-mm_slot-for-get_next_rmap_item.patch