The quilt patch titled Subject: kexec: use ALIGN macro instead of open-coding it has been removed from the -mm tree. Its filename was kexec-use-align-macro-instead-of-open-coding-it.patch This patch was dropped because it was merged into the mm-nonmm-stable branch of git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm ------------------------------------------------------ From: Yuntao Wang <ytcoode@xxxxxxxxx> Subject: kexec: use ALIGN macro instead of open-coding it Date: Tue, 12 Dec 2023 22:27:06 +0800 Use ALIGN macro instead of open-coding it to improve code readability. Link: https://lkml.kernel.org/r/20231212142706.25149-1-ytcoode@xxxxxxxxx Signed-off-by: Yuntao Wang <ytcoode@xxxxxxxxx> Acked-by: Baoquan He <bhe@xxxxxxxxxx> Cc: "Eric W. Biederman" <ebiederm@xxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- kernel/kexec_core.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) --- a/kernel/kexec_core.c~kexec-use-align-macro-instead-of-open-coding-it +++ a/kernel/kexec_core.c @@ -432,7 +432,7 @@ static struct page *kimage_alloc_crash_c pages = NULL; size = (1 << order) << PAGE_SHIFT; - hole_start = (image->control_page + (size - 1)) & ~(size - 1); + hole_start = ALIGN(image->control_page, size); hole_end = hole_start + size - 1; while (hole_end <= crashk_res.end) { unsigned long i; @@ -449,7 +449,7 @@ static struct page *kimage_alloc_crash_c mend = mstart + image->segment[i].memsz - 1; if ((hole_end >= mstart) && (hole_start <= mend)) { /* Advance the hole to the end of the segment */ - hole_start = (mend + (size - 1)) & ~(size - 1); + hole_start = ALIGN(mend, size); hole_end = hole_start + size - 1; break; } _ Patches currently in -mm which might be from ytcoode@xxxxxxxxx are x86-crash-remove-the-unused-image-parameter-from-prepare_elf_headers.patch x86-crash-use-sz_1m-macro-instead-of-hardcoded-value.patch crash_core-fix-and-simplify-the-logic-of-crash_exclude_mem_range.patch x86-crash-fix-potential-cmem-ranges-array-overflow.patch crash_core-optimize-crash_exclude_mem_range.patch kexec-modify-the-meaning-of-the-end-parameter-in-kimage_is_destination_range.patch kexec_file-fix-incorrect-temp_start-value-in-locate_mem_hole_top_down.patch x86-kexec-use-pr_err-instead-of-kexec_dprintk-when-an-error-occurs.patch x86-kexec-fix-incorrect-argument-passed-to-kexec_dprintk.patch