The patch titled Subject: x86/kexec: use pr_err() instead of kexec_dprintk() when an error occurs has been added to the -mm mm-nonmm-unstable branch. Its filename is x86-kexec-use-pr_err-instead-of-kexec_dprintk-when-an-error-occurs.patch This patch will shortly appear at https://git.kernel.org/pub/scm/linux/kernel/git/akpm/25-new.git/tree/patches/x86-kexec-use-pr_err-instead-of-kexec_dprintk-when-an-error-occurs.patch This patch will later appear in the mm-nonmm-unstable branch at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next via the mm-everything branch at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm and is updated there every 2-3 working days ------------------------------------------------------ From: Yuntao Wang <ytcoode@xxxxxxxxx> Subject: x86/kexec: use pr_err() instead of kexec_dprintk() when an error occurs Date: Wed, 20 Dec 2023 11:01:24 +0800 When detecting an error, the current code uses kexec_dprintk() to output log message. This is not quite appropriate as kexec_dprintk() is mainly used for outputting debugging messages, rather than error messages. Replace kexec_dprintk() with pr_err(). This also makes the output method for this error log align with the output method for other error logs in this function. Additionally, the last return statement in set_page_address() is unnecessary, remove it. Link: https://lkml.kernel.org/r/20231220030124.149160-1-ytcoode@xxxxxxxxx Signed-off-by: Yuntao Wang <ytcoode@xxxxxxxxx> Cc: Baoquan He <bhe@xxxxxxxxxx> Cc: Borislav Petkov (AMD) <bp@xxxxxxxxx> Cc: Dave Hansen <dave.hansen@xxxxxxxxxxxxxxx> Cc: "Eric W. Biederman" <ebiederm@xxxxxxxxxxxx> Cc: "H. Peter Anvin" <hpa@xxxxxxxxx> Cc: Ingo Molnar <mingo@xxxxxxxxxx> Cc: Jonathan Corbet <corbet@xxxxxxx> Cc: Thomas Gleixner <tglx@xxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- arch/x86/kernel/kexec-bzimage64.c | 2 +- mm/highmem.c | 2 -- 2 files changed, 1 insertion(+), 3 deletions(-) --- a/arch/x86/kernel/kexec-bzimage64.c~x86-kexec-use-pr_err-instead-of-kexec_dprintk-when-an-error-occurs +++ a/arch/x86/kernel/kexec-bzimage64.c @@ -429,7 +429,7 @@ static void *bzImage64_load(struct kimag * command line. Make sure it does not overflow */ if (cmdline_len + MAX_ELFCOREHDR_STR_LEN > header->cmdline_size) { - kexec_dprintk("Appending elfcorehdr=<addr> to command line exceeds maximum allowed length\n"); + pr_err("Appending elfcorehdr=<addr> to command line exceeds maximum allowed length\n"); return ERR_PTR(-EINVAL); } --- a/mm/highmem.c~x86-kexec-use-pr_err-instead-of-kexec_dprintk-when-an-error-occurs +++ a/mm/highmem.c @@ -799,8 +799,6 @@ void set_page_address(struct page *page, } spin_unlock_irqrestore(&pas->lock, flags); } - - return; } void __init page_address_init(void) _ Patches currently in -mm which might be from ytcoode@xxxxxxxxx are kexec-use-align-macro-instead-of-open-coding-it.patch x86-kexec-simplify-the-logic-of-mem_region_callback.patch x86-crash-remove-the-unused-image-parameter-from-prepare_elf_headers.patch x86-crash-use-sz_1m-macro-instead-of-hardcoded-value.patch crash_core-fix-and-simplify-the-logic-of-crash_exclude_mem_range.patch x86-crash-fix-potential-cmem-ranges-array-overflow.patch crash_core-optimize-crash_exclude_mem_range.patch kexec-modify-the-meaning-of-the-end-parameter-in-kimage_is_destination_range.patch kexec_file-fix-incorrect-temp_start-value-in-locate_mem_hole_top_down.patch x86-kexec-use-pr_err-instead-of-kexec_dprintk-when-an-error-occurs.patch