The patch titled Subject: seq_file: add helper macro to define attribute for rw file has been added to the -mm mm-nonmm-unstable branch. Its filename is seq_file-add-helper-macro-to-define-attribute-for-rw-file.patch This patch will shortly appear at https://git.kernel.org/pub/scm/linux/kernel/git/akpm/25-new.git/tree/patches/seq_file-add-helper-macro-to-define-attribute-for-rw-file.patch This patch will later appear in the mm-nonmm-unstable branch at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next via the mm-everything branch at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm and is updated there every 2-3 working days ------------------------------------------------------ From: Xingui Yang <yangxingui@xxxxxxxxxx> Subject: seq_file: add helper macro to define attribute for rw file Date: Tue, 5 Sep 2023 02:48:33 +0000 Patch series "Add helper macro DEFINE_SHOW_STORE_ATTRIBUTE() at seq_file.c", v6. We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute for read-only file, but we found many of drivers also want a helper macro for read-write file too. So we add this helper macro to reduce duplicated code. This patch (of 3): We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute for read-only file, but many of drivers want a helper macro for read-write file too. So we add DEFINE_SHOW_STORE_ATTRIBUTE() helper to reduce duplicated code. Link: https://lkml.kernel.org/r/20230905024835.43219-1-yangxingui@xxxxxxxxxx Link: https://lkml.kernel.org/r/20230905024835.43219-2-yangxingui@xxxxxxxxxx Signed-off-by: Luo Jiaxing <luojiaxing@xxxxxxxxxx> Co-developed-by: Xingui Yang <yangxingui@xxxxxxxxxx> Signed-off-by: Xingui Yang <yangxingui@xxxxxxxxxx> Reviewed-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> Cc: Al Viro <viro@xxxxxxxxxxxxxxxxxx> Cc: Animesh Manna <animesh.manna@xxxxxxxxx> Cc: Anshuman Gupta <anshuman.gupta@xxxxxxxxx> Cc: Damien Le Moal <damien.lemoal@xxxxxxxxxxxxxxxxxx> Cc: Felipe Balbi <felipe.balbi@xxxxxxxxxxxxxxx> Cc: Greg Kroah-Hartman <gregkh@xxxxxxxxxxxxxxxxxxx> Cc: Himanshu Madhani <himanshu.madhani@xxxxxxxxxx> Cc: James Bottomley <jejb@xxxxxxxxxxxxx> Cc: John Garry <john.g.garry@xxxxxxxxxx> Cc: Martin K. Petersen <martin.petersen@xxxxxxxxxx> Cc: Uma Shankar <uma.shankar@xxxxxxxxx> Cc: Xiang Chen <chenxiang66@xxxxxxxxxxxxx> Cc: Zeng Tao <prime.zeng@xxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- include/linux/seq_file.h | 15 +++++++++++++++ 1 file changed, 15 insertions(+) --- a/include/linux/seq_file.h~seq_file-add-helper-macro-to-define-attribute-for-rw-file +++ a/include/linux/seq_file.h @@ -207,6 +207,21 @@ static const struct file_operations __na .release = single_release, \ } +#define DEFINE_SHOW_STORE_ATTRIBUTE(__name) \ +static int __name ## _open(struct inode *inode, struct file *file) \ +{ \ + return single_open(file, __name ## _show, inode->i_private); \ +} \ + \ +static const struct file_operations __name ## _fops = { \ + .owner = THIS_MODULE, \ + .open = __name ## _open, \ + .read = seq_read, \ + .write = __name ## _write, \ + .llseek = seq_lseek, \ + .release = single_release, \ +} + #define DEFINE_PROC_SHOW_ATTRIBUTE(__name) \ static int __name ## _open(struct inode *inode, struct file *file) \ { \ _ Patches currently in -mm which might be from yangxingui@xxxxxxxxxx are seq_file-add-helper-macro-to-define-attribute-for-rw-file.patch scsi-hisi_sas-use-define_show_store_attribute-helper-for-debugfs.patch scsi-qla2xxx-use-define_show_store_attribute-helper-for-debugfs.patch