The patch titled Subject: zram: rename __zram_bvec_read to zram_read_page has been added to the -mm mm-unstable branch. Its filename is zram-rename-__zram_bvec_read-to-zram_read_page.patch This patch will shortly appear at https://git.kernel.org/pub/scm/linux/kernel/git/akpm/25-new.git/tree/patches/zram-rename-__zram_bvec_read-to-zram_read_page.patch This patch will later appear in the mm-unstable branch at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next via the mm-everything branch at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm and is updated there every 2-3 working days ------------------------------------------------------ From: Christoph Hellwig <hch@xxxxxx> Subject: zram: rename __zram_bvec_read to zram_read_page Date: Tue, 11 Apr 2023 19:14:51 +0200 __zram_bvec_read doesn't get passed a bvec, but always read a whole page. Rename it to make the usage more clear. Link: https://lkml.kernel.org/r/20230411171459.567614-10-hch@xxxxxx Signed-off-by: Christoph Hellwig <hch@xxxxxx> Reviewed-by: Sergey Senozhatsky <senozhatsky@xxxxxxxxxxxx> Acked-by: Minchan Kim <minchan@xxxxxxxxxx> Cc: Jens Axboe <axboe@xxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- drivers/block/zram/zram_drv.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-) --- a/drivers/block/zram/zram_drv.c~zram-rename-__zram_bvec_read-to-zram_read_page +++ a/drivers/block/zram/zram_drv.c @@ -1397,8 +1397,8 @@ static int zram_read_from_zspool(struct return ret; } -static int __zram_bvec_read(struct zram *zram, struct page *page, u32 index, - struct bio *bio, bool partial_io) +static int zram_read_page(struct zram *zram, struct page *page, u32 index, + struct bio *bio, bool partial_io) { int ret; @@ -1436,7 +1436,7 @@ static int zram_bvec_read(struct zram *z return -ENOMEM; } - ret = __zram_bvec_read(zram, page, index, bio, is_partial_io(bvec)); + ret = zram_read_page(zram, page, index, bio, is_partial_io(bvec)); if (unlikely(ret)) goto out; @@ -1593,7 +1593,7 @@ static int zram_bvec_write(struct zram * if (!page) return -ENOMEM; - ret = __zram_bvec_read(zram, page, index, bio, true); + ret = zram_read_page(zram, page, index, bio, true); if (ret) goto out; _ Patches currently in -mm which might be from hch@xxxxxx are zram-always-compile-read_from_bdev_sync.patch zram-remove-valid_io_request.patch zram-make-zram_bio_discard-more-self-contained.patch zram-simplify-bvec-iteration-in-__zram_make_request.patch zram-move-discard-handling-to-zram_submit_bio.patch zram-return-early-on-error-in-zram_bvec_rw.patch zram-refactor-highlevel-read-and-write-handling.patch zram-dont-use-highmem-for-the-bounce-buffer-in-zram_bvec_readwrite.patch zram-rename-__zram_bvec_read-to-zram_read_page.patch zram-directly-call-zram_read_page-in-writeback_store.patch zram-refactor-zram_bdev_read.patch zram-dont-pass-a-bvec-to-__zram_bvec_write.patch zram-refactor-zram_bdev_write.patch zram-pass-a-page-to-read_from_bdev.patch zram-dont-return-errors-from-read_from_bdev_async.patch zram-fix-synchronous-reads.patch zram-return-errors-from-read_from_bdev_sync.patch