The quilt patch titled Subject: maple_tree: use macro MA_ROOT_PARENT instead of number has been removed from the -mm tree. Its filename was maple_tree-use-macro-ma_root_parent-instead-of-number.patch This patch was dropped because it was merged into the mm-stable branch of git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm ------------------------------------------------------ From: Vernon Yang <vernon2gm@xxxxxxxxx> Subject: maple_tree: use macro MA_ROOT_PARENT instead of number Date: Wed, 21 Dec 2022 14:00:55 +0800 When you need to compare whether node->parent is parent of the root node, using macro MA_ROOT_PARENT is easier to understand and for better readability. Link: https://lkml.kernel.org/r/20221221060058.609003-5-vernon2gm@xxxxxxxxx Signed-off-by: Vernon Yang <vernon2gm@xxxxxxxxx> Reviewed-by: Liam R. Howlett <Liam.Howlett@xxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- lib/maple_tree.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) --- a/lib/maple_tree.c~maple_tree-use-macro-ma_root_parent-instead-of-number +++ a/lib/maple_tree.c @@ -503,8 +503,7 @@ static inline unsigned int mte_parent_sl { unsigned long val = (unsigned long)mte_to_node(enode)->parent; - /* Root. */ - if (val & 1) + if (val & MA_ROOT_PARENT) return 0; /* _ Patches currently in -mm which might be from vernon2gm@xxxxxxxxx are maple_tree-remove-the-parameter-entry-of-mas_preallocate.patch mm-mmap-fix-typo-in-comment.patch maple_tree-fix-comment-of-mte_destroy_walk.patch mm-mmap-fix-comment-of-unmapped_area_topdown.patch