The quilt patch titled Subject: mm: vmscan: use sysfs_emit() to instead of scnprintf() has been removed from the -mm tree. Its filename was mm-vmscan-use-sysfs_emit-to-instead-of-scnprintf.patch This patch was dropped because it was merged into the mm-stable branch of git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm ------------------------------------------------------ From: Xu Panda <xu.panda@xxxxxxxxxx> Subject: mm: vmscan: use sysfs_emit() to instead of scnprintf() Date: Thu, 24 Nov 2022 19:29:01 +0800 (CST) Replace open-coded snprintf() with sysfs_emit() to simplify the code. Link: https://lkml.kernel.org/r/202211241929015476424@xxxxxxxxxx Signed-off-by: Xu Panda <xu.panda@xxxxxxxxxx> Signed-off-by: Yang Yang <yang.yang29@xxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/vmscan.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) --- a/mm/vmscan.c~mm-vmscan-use-sysfs_emit-to-instead-of-scnprintf +++ a/mm/vmscan.c @@ -5407,7 +5407,7 @@ static ssize_t show_enabled(struct kobje if (arch_has_hw_nonleaf_pmd_young() && get_cap(LRU_GEN_NONLEAF_YOUNG)) caps |= BIT(LRU_GEN_NONLEAF_YOUNG); - return snprintf(buf, PAGE_SIZE, "0x%04x\n", caps); + return sysfs_emit(buf, "0x%04x\n", caps); } /* see Documentation/admin-guide/mm/multigen_lru.rst for details */ _ Patches currently in -mm which might be from xu.panda@xxxxxxxxxx are relay-use-strscpy-is-more-robust-and-safer.patch