The quilt patch titled Subject: mm/mempolicy: use PAGE_ALIGN instead of open-coding it has been removed from the -mm tree. Its filename was mm-mempolicy-use-page_align-instead-of-open-coding-it.patch This patch was dropped because it was merged into the mm-stable branch of git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm ------------------------------------------------------ From: ze zuo <zuoze1@xxxxxxxxxx> Subject: mm/mempolicy: use PAGE_ALIGN instead of open-coding it Date: Tue, 13 Sep 2022 01:55:05 +0000 Replace the simple calculation with PAGE_ALIGN. Link: https://lkml.kernel.org/r/20220913015505.1998958-1-zuoze1@xxxxxxxxxx Signed-off-by: ze zuo <zuoze1@xxxxxxxxxx> Reviewed-by: Muchun Song <songmuchun@xxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/mempolicy.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) --- a/mm/mempolicy.c~mm-mempolicy-use-page_align-instead-of-open-coding-it +++ a/mm/mempolicy.c @@ -1270,7 +1270,7 @@ static long do_mbind(unsigned long start if (mode == MPOL_DEFAULT) flags &= ~MPOL_MF_STRICT; - len = (len + PAGE_SIZE - 1) & PAGE_MASK; + len = PAGE_ALIGN(len); end = start + len; if (end < start) @@ -1507,7 +1507,7 @@ SYSCALL_DEFINE4(set_mempolicy_home_node, if (home_node >= MAX_NUMNODES || !node_online(home_node)) return -EINVAL; - len = (len + PAGE_SIZE - 1) & PAGE_MASK; + len = PAGE_ALIGN(len); end = start + len; if (end < start) _ Patches currently in -mm which might be from zuoze1@xxxxxxxxxx are