The patch titled Subject: ia64: module: use swap() to make code cleaner has been removed from the -mm tree. Its filename was ia64-module-use-swap-to-make-code-cleaner.patch This patch was dropped because it was merged into mainline or a subsystem tree ------------------------------------------------------ From: Yang Guang <yang.guang5@xxxxxxxxxx> Subject: ia64: module: use swap() to make code cleaner Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid opencoding it. Link: https://lkml.kernel.org/r/20211104062642.1506539-1-yang.guang5@xxxxxxxxxx Signed-off-by: Yang Guang <yang.guang5@xxxxxxxxxx> Reported-by: Zeal Robot <zealci@xxxxxxxxxx> Cc: David Yang <davidcomponentone@xxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- arch/ia64/kernel/module.c | 6 ++---- 1 file changed, 2 insertions(+), 4 deletions(-) --- a/arch/ia64/kernel/module.c~ia64-module-use-swap-to-make-code-cleaner +++ a/arch/ia64/kernel/module.c @@ -848,7 +848,7 @@ register_unwind_table (struct module *mo { struct unw_table_entry *start = (void *) mod->arch.unwind->sh_addr; struct unw_table_entry *end = start + mod->arch.unwind->sh_size / sizeof (*start); - struct unw_table_entry tmp, *e1, *e2, *core, *init; + struct unw_table_entry *e1, *e2, *core, *init; unsigned long num_init = 0, num_core = 0; /* First, count how many init and core unwind-table entries there are. */ @@ -865,9 +865,7 @@ register_unwind_table (struct module *mo for (e1 = start; e1 < end; ++e1) { for (e2 = e1 + 1; e2 < end; ++e2) { if (e2->start_offset < e1->start_offset) { - tmp = *e1; - *e1 = *e2; - *e2 = tmp; + swap(*e1, *e2); } } } _ Patches currently in -mm which might be from yang.guang5@xxxxxxxxxx are