The patch titled Subject: mm: migrate: change to use bool type for 'page_was_mapped' has been added to the -mm tree. Its filename is mm-migrate-change-to-use-bool-type-for-page_was_mapped.patch This patch should soon appear at https://ozlabs.org/~akpm/mmots/broken-out/mm-migrate-change-to-use-bool-type-for-page_was_mapped.patch and later at https://ozlabs.org/~akpm/mmotm/broken-out/mm-migrate-change-to-use-bool-type-for-page_was_mapped.patch Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next and is updated there every 3-4 working days ------------------------------------------------------ From: Baolin Wang <baolin.wang@xxxxxxxxxxxxxxxxx> Subject: mm: migrate: change to use bool type for 'page_was_mapped' Change to use bool type for 'page_was_mapped' variable making it more readable. Link: https://lkml.kernel.org/r/ce1279df18d2c163998c403e0b5ec6d3f6f90f7a.1629447552.git.baolin.wang@xxxxxxxxxxxxxxxxx Signed-off-by: Baolin Wang <baolin.wang@xxxxxxxxxxxxxxxxx> Reviewed-by: Yang Shi <shy828301@xxxxxxxxx> Cc: Alistair Popple <apopple@xxxxxxxxxx> Cc: Matthew Wilcox <willy@xxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/migrate.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) --- a/mm/migrate.c~mm-migrate-change-to-use-bool-type-for-page_was_mapped +++ a/mm/migrate.c @@ -953,7 +953,7 @@ static int __unmap_and_move(struct page int force, enum migrate_mode mode) { int rc = -EAGAIN; - int page_was_mapped = 0; + bool page_was_mapped = false; struct anon_vma *anon_vma = NULL; bool is_lru = !__PageMovable(page); @@ -1056,7 +1056,7 @@ static int __unmap_and_move(struct page VM_BUG_ON_PAGE(PageAnon(page) && !PageKsm(page) && !anon_vma, page); try_to_migrate(page, 0); - page_was_mapped = 1; + page_was_mapped = true; } if (!page_mapped(page)) _ Patches currently in -mm which might be from baolin.wang@xxxxxxxxxxxxxxxxx are mm-memcontrol-set-the-correct-memcg-swappiness-restriction.patch mm-mempolicy-use-readable-numa_no_node-macro-instead-of-magic-numer.patch mm-migrate-simplify-the-file-backed-pages-validation-when-migrating-its-mapping.patch mm-migrate-introduce-a-local-variable-to-get-the-number-of-pages.patch mm-migrate-fix-the-incorrect-function-name-in-comments.patch mm-migrate-change-to-use-bool-type-for-page_was_mapped.patch