The patch titled Subject: mm/zsmalloc.c: remove confusing code in obj_free() has been removed from the -mm tree. Its filename was mm-zsmallocc-remove-confusing-code-in-obj_free.patch This patch was dropped because it was merged into mainline or a subsystem tree ------------------------------------------------------ From: Miaohe Lin <linmiaohe@xxxxxxxxxx> Subject: mm/zsmalloc.c: remove confusing code in obj_free() Patch series "Cleanup for zsmalloc". This series contains cleanups to remove confusing code in obj_free(), combine two atomic ops and improve readability for async_free_zspage(). More details can be found in the respective changelogs. This patch (of 2): OBJ_ALLOCATED_TAG is only set for handle to indicate allocated object. It's irrelevant with obj. So remove this misleading code to improve readability. Link: https://lkml.kernel.org/r/20210624123930.1769093-1-linmiaohe@xxxxxxxxxx Link: https://lkml.kernel.org/r/20210624123930.1769093-2-linmiaohe@xxxxxxxxxx Signed-off-by: Miaohe Lin <linmiaohe@xxxxxxxxxx> Cc: Minchan Kim <minchan@xxxxxxxxxx> Cc: Nitin Gupta <ngupta@xxxxxxxxxx> Cc: Sergey Senozhatsky <senozhatsky@xxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/zsmalloc.c | 1 - 1 file changed, 1 deletion(-) --- a/mm/zsmalloc.c~mm-zsmallocc-remove-confusing-code-in-obj_free +++ a/mm/zsmalloc.c @@ -1471,7 +1471,6 @@ static void obj_free(struct size_class * unsigned int f_objidx; void *vaddr; - obj &= ~OBJ_ALLOCATED_TAG; obj_to_location(obj, &f_page, &f_objidx); f_offset = (class->size * f_objidx) & ~PAGE_MASK; zspage = get_zspage(f_page); _ Patches currently in -mm which might be from linmiaohe@xxxxxxxxxx are mm-zsmallocc-combine-two-atomic-ops-in-zs_pool_dec_isolated.patch