The patch titled Subject: mm/vmscan.c: use add_page_to_lru_list() has been added to the -mm tree. Its filename is mm-use-add_page_to_lru_list.patch This patch should soon appear at https://ozlabs.org/~akpm/mmots/broken-out/mm-use-add_page_to_lru_list.patch and later at https://ozlabs.org/~akpm/mmotm/broken-out/mm-use-add_page_to_lru_list.patch Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next and is updated there every 3-4 working days ------------------------------------------------------ From: Yu Zhao <yuzhao@xxxxxxxxxx> Subject: mm/vmscan.c: use add_page_to_lru_list() Patch series "mm: lru related cleanups", v2. The cleanups are intended to reduce the verbosity in lru list operations and make them less error-prone. A typical example would be how the patches change __activate_page(): static void __activate_page(struct page *page, struct lruvec *lruvec) { if (!PageActive(page) && !PageUnevictable(page)) { - int lru = page_lru_base_type(page); int nr_pages = thp_nr_pages(page); - del_page_from_lru_list(page, lruvec, lru); + del_page_from_lru_list(page, lruvec); SetPageActive(page); - lru += LRU_ACTIVE; - add_page_to_lru_list(page, lruvec, lru); + add_page_to_lru_list(page, lruvec); trace_mm_lru_activate(page); There are a few more places like __activate_page() and they are unnecessarily repetitive in terms of figuring out which list a page should be added onto or deleted from. And with the duplicated code removed, they are easier to read, IMO. Patch 1 to 5 basically cover the above. Patch 6 and 7 make code more robust by improving bug reporting. Patch 8, 9 and 10 take care of some dangling helpers left in header files. This patch (of 10): There is add_page_to_lru_list(), and move_pages_to_lru() should reuse it, not duplicate it. Link: https://lkml.kernel.org/r/20210122220600.906146-1-yuzhao@xxxxxxxxxx Link: https://lore.kernel.org/linux-mm/20201207220949.830352-2-yuzhao@xxxxxxxxxx/ Link: https://lkml.kernel.org/r/20210122220600.906146-2-yuzhao@xxxxxxxxxx Signed-off-by: Yu Zhao <yuzhao@xxxxxxxxxx> Reviewed-by: Alex Shi <alex.shi@xxxxxxxxxxxxxxxxx> Cc: Hugh Dickins <hughd@xxxxxxxxxx> Cc: Michal Hocko <mhocko@xxxxxxxxxx> Cc: Johannes Weiner <hannes@xxxxxxxxxxx> Cc: Vladimir Davydov <vdavydov.dev@xxxxxxxxx> Cc: Roman Gushchin <guro@xxxxxx> Cc: Vlastimil Babka <vbabka@xxxxxxx> Cc: Matthew Wilcox <willy@xxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/vmscan.c | 6 +----- 1 file changed, 1 insertion(+), 5 deletions(-) --- a/mm/vmscan.c~mm-use-add_page_to_lru_list +++ a/mm/vmscan.c @@ -1823,7 +1823,6 @@ static unsigned noinline_for_stack move_ int nr_pages, nr_moved = 0; LIST_HEAD(pages_to_free); struct page *page; - enum lru_list lru; while (!list_empty(list)) { page = lru_to_page(list); @@ -1868,11 +1867,8 @@ static unsigned noinline_for_stack move_ * inhibits memcg migration). */ VM_BUG_ON_PAGE(!lruvec_holds_page_lru_lock(page, lruvec), page); - lru = page_lru(page); + add_page_to_lru_list(page, lruvec, page_lru(page)); nr_pages = thp_nr_pages(page); - - update_lru_size(lruvec, lru, page_zonenum(page), nr_pages); - list_add(&page->lru, &lruvec->lists[lru]); nr_moved += nr_pages; if (PageActive(page)) workingset_age_nonresident(lruvec, nr_pages); _ Patches currently in -mm which might be from yuzhao@xxxxxxxxxx are mm-swap-dont-setpageworkingset-unconditionally-during-swapin.patch mm-use-add_page_to_lru_list.patch mm-shuffle-lru-list-addition-and-deletion-functions.patch mm-dont-pass-enum-lru_list-to-lru-list-addition-functions.patch mm-dont-pass-enum-lru_list-to-trace_mm_lru_insertion.patch mm-dont-pass-enum-lru_list-to-del_page_from_lru_list.patch mm-add-__clear_page_lru_flags-to-replace-page_off_lru.patch mm-vm_bug_on-lru-page-flags.patch mm-fold-page_lru_base_type-into-its-sole-caller.patch mm-fold-__update_lru_size-into-its-sole-caller.patch mm-make-lruvec_lru_size-static.patch