The patch titled Subject: hugetlbfs: correct obsolete function name in hugetlbfs_read_iter() has been added to the -mm tree. Its filename is hugetlbfs-correct-obsolete-function-name-in-hugetlbfs_read_iter.patch This patch should soon appear at https://ozlabs.org/~akpm/mmots/broken-out/hugetlbfs-correct-obsolete-function-name-in-hugetlbfs_read_iter.patch and later at https://ozlabs.org/~akpm/mmotm/broken-out/hugetlbfs-correct-obsolete-function-name-in-hugetlbfs_read_iter.patch Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next and is updated there every 3-4 working days ------------------------------------------------------ From: Miaohe Lin <linmiaohe@xxxxxxxxxx> Subject: hugetlbfs: correct obsolete function name in hugetlbfs_read_iter() Since commit 36e789144267 ("kill do_generic_mapping_read"), the function do_generic_mapping_read() is renamed to do_generic_file_read(). And then commit 47c27bc46946 ("fs: pass iocb to do_generic_file_read") renamed it to generic_file_buffered_read(). So replace do_generic_mapping_read() with generic_file_buffered_read() to keep comment uptodate. Link: https://lkml.kernel.org/r/20210118063210.47118-1-linmiaohe@xxxxxxxxxx Signed-off-by: Miaohe Lin <linmiaohe@xxxxxxxxxx> Reviewed-by: Mike Kravetz <mike.kravetz@xxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- fs/hugetlbfs/inode.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) --- a/fs/hugetlbfs/inode.c~hugetlbfs-correct-obsolete-function-name-in-hugetlbfs_read_iter +++ a/fs/hugetlbfs/inode.c @@ -310,7 +310,7 @@ hugetlbfs_read_actor(struct page *page, /* * Support for read() - Find the page attached to f_mapping and copy out the - * data. Its *very* similar to do_generic_mapping_read(), we can't use that + * data. Its *very* similar to generic_file_buffered_read(), we can't use that * since it has PAGE_SIZE assumptions. */ static ssize_t hugetlbfs_read_iter(struct kiocb *iocb, struct iov_iter *to) _ Patches currently in -mm which might be from linmiaohe@xxxxxxxxxx are mm-hugetlb-fix-potential-double-free-in-hugetlb_register_node-error-path.patch mm-hugetlb-avoid-unnecessary-hugetlb_acct_memory-call.patch mm-hugetlb-use-helper-huge_page_order-and-pages_per_huge_page.patch mm-compaction-remove-duplicated-vm_bug_on_page-pagelocked.patch hugetlbfs-remove-useless-bug_oninode-in-hugetlbfs_setattr.patch hugetlbfs-use-helper-macro-default_hstate-in-init_hugetlbfs_fs.patch hugetlbfs-correct-obsolete-function-name-in-hugetlbfs_read_iter.patch mm-zsmallocc-convert-to-use-kmem_cache_zalloc-in-cache_alloc_zspage.patch