The patch titled Subject: zsmalloc: switch from alloc_vm_area to get_vm_area has been added to the -mm tree. Its filename is zsmalloc-switch-from-alloc_vm_area-to-get_vm_area.patch This patch should soon appear at https://ozlabs.org/~akpm/mmots/broken-out/zsmalloc-switch-from-alloc_vm_area-to-get_vm_area.patch and later at https://ozlabs.org/~akpm/mmotm/broken-out/zsmalloc-switch-from-alloc_vm_area-to-get_vm_area.patch Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next and is updated there every 3-4 working days ------------------------------------------------------ From: Christoph Hellwig <hch@xxxxxx> Subject: zsmalloc: switch from alloc_vm_area to get_vm_area Patch series "remove alloc_vm_area". This series removes alloc_vm_area, which was left over from the big vmalloc interface rework. It is a rather arcane interface, basically the equivalent of get_vm_area + actually faulting in all PTEs in the allocated area. It was originally addeds for Xen (which isn't modular to start with), and then grew users in zsmalloc and i915 which seems to mostly qualify as abuses of the interface, especially for i915 as a random driver should not set up PTE bits directly. Note that my laptop doesn't seem to actually exercise the new vmap_pfn path, so careful review from the i915 maintainers is very welcome. Also I wonder why zsmalloc is even doing the manual allocation of kernel virtual address space plus mapping into it. IMHO zsmalloc should be using our normal vm_map_ram / vm_unmap_ram interface instead of being so special, which would also allow building it as a module again for the virtual mapping case. This patch (of 6): There is no obvious reason why zsmalloc needs to pre-fault the PTEs given that it later uses map_kernel_range to just like vmap(). Link: https://lkml.kernel.org/r/20200918163724.2511-2-hch@xxxxxx Signed-off-by: Christoph Hellwig <hch@xxxxxx> Cc: Peter Zijlstra <peterz@xxxxxxxxxxxxx> Cc: Boris Ostrovsky <boris.ostrovsky@xxxxxxxxxx> Cc: Juergen Gross <jgross@xxxxxxxx> Cc: Stefano Stabellini <sstabellini@xxxxxxxxxx> Cc: Jani Nikula <jani.nikula@xxxxxxxxxxxxxxx> Cc: Joonas Lahtinen <joonas.lahtinen@xxxxxxxxxxxxxxx> Cc: Rodrigo Vivi <rodrigo.vivi@xxxxxxxxx> Cc: Minchan Kim <minchan@xxxxxxxxxx> Cc: Nitin Gupta <ngupta@xxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/zsmalloc.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) --- a/mm/zsmalloc.c~zsmalloc-switch-from-alloc_vm_area-to-get_vm_area +++ a/mm/zsmalloc.c @@ -1122,7 +1122,7 @@ static inline int __zs_cpu_up(struct map */ if (area->vm) return 0; - area->vm = alloc_vm_area(PAGE_SIZE * 2, NULL); + area->vm = get_vm_area(PAGE_SIZE * 2, 0); if (!area->vm) return -ENOMEM; return 0; _ Patches currently in -mm which might be from hch@xxxxxx are zsmalloc-switch-from-alloc_vm_area-to-get_vm_area.patch mm-add-a-vmap_pfn-function.patch drm-i915-use-vmap-in-shmem_pin_map.patch drm-i915-use-vmap-in-i915_gem_object_map.patch xen-xenbus-use-apply_to_page_range-directly-in-xenbus_map_ring_pv.patch x86-xen-open-code-alloc_vm_area-in-arch_gnttab_valloc.patch