The patch titled uml ubd driver: give better names to some functions. has been added to the -mm tree. Its filename is uml-ubd-driver-give-better-names-to-some-functions.patch See http://www.zip.com.au/~akpm/linux/patches/stuff/added-to-mm.txt to find out what to do about this ------------------------------------------------------ Subject: uml ubd driver: give better names to some functions. From: Paolo 'Blaisorblade' Giarrusso <blaisorblade@xxxxxxxx> To rethink locking, I needed to understand well what each function does. While doing this I renamed some: * ubd_close -> ubd_close_dev (since it pairs with ubd_open_dev) * ubd_new_disk -> ubd_disk_register (it handles registration with the block layer - one hopes this makes clearer the difference with ubd_add()) Signed-off-by: Paolo 'Blaisorblade' Giarrusso <blaisorblade@xxxxxxxx> Cc: Jeff Dike <jdike@xxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxx> --- arch/um/drivers/ubd_kern.c | 12 ++++++------ 1 file changed, 6 insertions(+), 6 deletions(-) diff -puN arch/um/drivers/ubd_kern.c~uml-ubd-driver-give-better-names-to-some-functions arch/um/drivers/ubd_kern.c --- a/arch/um/drivers/ubd_kern.c~uml-ubd-driver-give-better-names-to-some-functions +++ a/arch/um/drivers/ubd_kern.c @@ -552,7 +552,7 @@ static int ubd_file_size(struct ubd *ubd return(os_file_size(file, size_out)); } -static void ubd_close(struct ubd *ubd_dev) +static void ubd_close_dev(struct ubd *ubd_dev) { os_close_file(ubd_dev->fd); if(ubd_dev->cow.file == NULL) @@ -624,7 +624,7 @@ static int ubd_open_dev(struct ubd *ubd_ return(err); } -static int ubd_new_disk(int major, u64 size, int unit, +static int ubd_disk_register(int major, u64 size, int unit, struct gendisk **disk_out) { @@ -676,12 +676,12 @@ static int ubd_add(int n) ubd_dev->size = ROUND_BLOCK(ubd_dev->size); - err = ubd_new_disk(MAJOR_NR, ubd_dev->size, n, &ubd_gendisk[n]); + err = ubd_disk_register(MAJOR_NR, ubd_dev->size, n, &ubd_gendisk[n]); if(err) goto out; if(fake_major != MAJOR_NR) - ubd_new_disk(fake_major, ubd_dev->size, n, + ubd_disk_register(fake_major, ubd_dev->size, n, &fake_gendisk[n]); /* perhaps this should also be under the "if (fake_major)" above */ @@ -898,7 +898,7 @@ static int ubd_open(struct inode *inode, /* This should no more be needed. And it didn't work anyway to exclude * read-write remounting of filesystems.*/ /*if((filp->f_mode & FMODE_WRITE) && !ubd_dev->openflags.w){ - if(--ubd_dev->count == 0) ubd_close(ubd_dev); + if(--ubd_dev->count == 0) ubd_close_dev(ubd_dev); err = -EROFS; }*/ out: @@ -911,7 +911,7 @@ static int ubd_release(struct inode * in struct ubd *ubd_dev = disk->private_data; if(--ubd_dev->count == 0) - ubd_close(ubd_dev); + ubd_close_dev(ubd_dev); return(0); } _ Patches currently in -mm which might be from blaisorblade@xxxxxxxx are fix-remove-the-use-of-_syscallx-macros-in-uml.patch uml-fix-compilation-options-for-user_objs.patch uml-ubd-driver-allow-using-up-to-16-ubd-devices.patch uml-ubd-driver-document-some-struct-fields.patch uml-ubd-driver-var-renames.patch uml-ubd-driver-give-better-names-to-some-functions.patch uml-ubd-driver-change-ubd_lock-to-be-a-mutex.patch uml-ubd-driver-ubd_io_lock-usage-fixup.patch uml-ubd-driver-reformat-ubd_config.patch uml-ubd-driver-convert-do_ubd-to-a-boolean-variable.patch uml-ubd-driver-use-bitfields-where-possible.patch uml-ubd-driver-do-not-store-error-codes-as-fd.patch uml-ubd-driver-various-little-changes.patch uml-fix-prototypes.patch uml-make-execvp-safe-for-our-usage.patch - To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html