The patch titled Subject: proc: use named enums for better readability has been added to the -mm tree. Its filename is proc-use-named-enums-for-better-readability.patch This patch should soon appear at http://ozlabs.org/~akpm/mmots/broken-out/proc-use-named-enums-for-better-readability.patch and later at http://ozlabs.org/~akpm/mmotm/broken-out/proc-use-named-enums-for-better-readability.patch Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next and is updated there every 3-4 working days ------------------------------------------------------ From: Alexey Gladkov <gladkov.alexey@xxxxxxxxx> Subject: proc: use named enums for better readability Link: http://lkml.kernel.org/r/20200419141057.621356-8-gladkov.alexey@xxxxxxxxx Signed-off-by: Alexey Gladkov <gladkov.alexey@xxxxxxxxx> Reviewed-by: Alexey Dobriyan <adobriyan@xxxxxxxxx> Reviewed-by: Kees Cook <keescook@xxxxxxxxxxxx> Cc: Akinobu Mita <akinobu.mita@xxxxxxxxx> Cc: Alexander Viro <viro@xxxxxxxxxxxxxxxxxx> Cc: Andy Lutomirski <luto@xxxxxxxxxx> Cc: Daniel Micay <danielmicay@xxxxxxxxx> Cc: David Howells <dhowells@xxxxxxxxxx> Cc: Djalal Harouni <tixxdz@xxxxxxxxx> Cc: "Dmitry V . Levin" <ldv@xxxxxxxxxxxx> Cc: "Eric W . Biederman" <ebiederm@xxxxxxxxxxxx> Cc: Greg Kroah-Hartman <gregkh@xxxxxxxxxxxxxxxxxxx> Cc: Ingo Molnar <mingo@xxxxxxxxxx> Cc: "J . Bruce Fields" <bfields@xxxxxxxxxxxx> Cc: Jeff Layton <jlayton@xxxxxxxxxxxxxxx> Cc: Jonathan Corbet <corbet@xxxxxxx> Cc: Oleg Nesterov <oleg@xxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- fs/proc/base.c | 2 +- fs/proc/inode.c | 2 +- fs/proc/root.c | 4 ++-- include/linux/proc_fs.h | 8 ++++---- 4 files changed, 8 insertions(+), 8 deletions(-) --- a/fs/proc/base.c~proc-use-named-enums-for-better-readability +++ a/fs/proc/base.c @@ -699,7 +699,7 @@ int proc_setattr(struct dentry *dentry, */ static bool has_pid_permissions(struct proc_fs_info *fs_info, struct task_struct *task, - int hide_pid_min) + enum proc_hidepid hide_pid_min) { /* * If 'hidpid' mount option is set force a ptrace check, --- a/fs/proc/inode.c~proc-use-named-enums-for-better-readability +++ a/fs/proc/inode.c @@ -166,7 +166,7 @@ void proc_invalidate_siblings_dcache(str deactivate_super(old_sb); } -static inline const char *hidepid2str(int v) +static inline const char *hidepid2str(enum proc_hidepid v) { switch (v) { case HIDEPID_OFF: return "off"; --- a/fs/proc/root.c~proc-use-named-enums-for-better-readability +++ a/fs/proc/root.c @@ -32,9 +32,9 @@ struct proc_fs_context { struct pid_namespace *pid_ns; unsigned int mask; - int hidepid; + enum proc_hidepid hidepid; int gid; - int pidonly; + enum proc_pidonly pidonly; }; enum proc_param { --- a/include/linux/proc_fs.h~proc-use-named-enums-for-better-readability +++ a/include/linux/proc_fs.h @@ -43,7 +43,7 @@ struct proc_ops { } __randomize_layout; /* definitions for hide_pid field */ -enum { +enum proc_hidepid { HIDEPID_OFF = 0, HIDEPID_NO_ACCESS = 1, HIDEPID_INVISIBLE = 2, @@ -51,7 +51,7 @@ enum { }; /* definitions for proc mount option pidonly */ -enum { +enum proc_pidonly { PROC_PIDONLY_OFF = 0, PROC_PIDONLY_ON = 1, }; @@ -61,8 +61,8 @@ struct proc_fs_info { struct dentry *proc_self; /* For /proc/self */ struct dentry *proc_thread_self; /* For /proc/thread-self */ kgid_t pid_gid; - int hide_pid; - int pidonly; + enum proc_hidepid hide_pid; + enum proc_pidonly pidonly; }; static inline struct proc_fs_info *proc_sb_info(struct super_block *sb) _ Patches currently in -mm which might be from gladkov.alexey@xxxxxxxxx are proc-rename-struct-proc_fs_info-to-proc_fs_opts.patch proc-allow-to-mount-many-instances-of-proc-in-one-pid-namespace.patch proc-instantiate-only-pids-that-we-can-ptrace-on-hidepid=4-mount-option.patch proc-add-option-to-mount-only-a-pids-subset.patch docs-proc-add-documentation-for-hidepid=4-and-subset=pid-options-and-new-mount-behavior.patch proc-use-human-readable-values-for-hidepid.patch proc-use-named-enums-for-better-readability.patch