The patch titled Subject: mm/swapfile.c: compare tmp and max after trying to iterate on swap_map has been removed from the -mm tree. Its filename was mm-swapfilec-compare-tmp-and-max-after-trying-to-iterate-on-swap_map.patch This patch was dropped because an updated version will be merged ------------------------------------------------------ From: Wei Yang <richard.weiyang@xxxxxxxxx> Subject: mm/swapfile.c: compare tmp and max after trying to iterate on swap_map There are two duplicate code to handle the case when there is no available swap entry. Just let the code go through and do the check at second place. No functional change is expected. Link: http://lkml.kernel.org/r/20200419013921.14390-3-richard.weiyang@xxxxxxxxx Signed-off-by: Wei Yang <richard.weiyang@xxxxxxxxx> Reviewed-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> Cc: Huang Ying <ying.huang@xxxxxxxxx> Cc: Hugh Dickins <hughd@xxxxxxxxxx> Cc: Tim Chen <tim.c.chen@xxxxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/swapfile.c | 4 ---- 1 file changed, 4 deletions(-) --- a/mm/swapfile.c~mm-swapfilec-compare-tmp-and-max-after-trying-to-iterate-on-swap_map +++ a/mm/swapfile.c @@ -629,10 +629,6 @@ new_cluster: tmp = cluster->next; max = min_t(unsigned long, si->max, (cluster_next(&cluster->index) + 1) * SWAPFILE_CLUSTER); - if (tmp >= max) { - cluster_set_null(&cluster->index); - goto new_cluster; - } ci = lock_cluster(si, tmp); while (tmp < max) { if (!si->swap_map[tmp]) _ Patches currently in -mm which might be from richard.weiyang@xxxxxxxxx are mm-swapfilec-offset-is-only-used-when-there-is-more-slots.patch mm-swapfilec-explicitly-show-ssd-non-ssd-is-handled-mutually-exclusive.patch mm-swapfilec-remove-the-unnecessary-goto-for-ssd-case.patch mm-swapfilec-simplify-the-calculation-of-n_goal.patch mm-swapfilec-remove-the-extra-check-in-scan_swap_map_slots.patch mm-swapfilec-move-new_cluster-to-check-free_clusters-directly.patch mm-page_allocc-bad_-is-not-necessary-when-pagehwpoison.patch mm-page_allocc-bad_flags-is-not-necessary-for-bad_page.patch mm-page_allocc-rename-free_pages_check_bad-to-check_free_page_bad.patch mm-page_allocc-rename-free_pages_check-to-check_free_page.patch mm-page_allocc-extract-check__page_bad-common-part-to-page_bad_reason.patch mm-page_allocc-use-node_mask_none-in-build_zonelists.patch mm-rename-gfpflags_to_migratetype-to-gfp_migratetype-for-same-convention.patch mm-vmscanc-use-update_lru_size-in-update_lru_sizes.patch