The patch titled Subject: mm/page_alloc.c: use free_area_empty() instead of open-coding has been removed from the -mm tree. Its filename was mm-page_alloc-use-free_area_empty-instead-of-open-coding.patch This patch was dropped because it was merged into mainline or a subsystem tree ------------------------------------------------------ From: chenqiwu <chenqiwu@xxxxxxxxxx> Subject: mm/page_alloc.c: use free_area_empty() instead of open-coding Use free_area_empty() API to replace list_empty() for better code readability. Link: http://lkml.kernel.org/r/1583674354-7713-1-git-send-email-qiwuchen55@xxxxxxxxx Signed-off-by: chenqiwu <chenqiwu@xxxxxxxxxx> Reviewed-by: Matthew Wilcox (Oracle) <willy@xxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/page_alloc.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) --- a/mm/page_alloc.c~mm-page_alloc-use-free_area_empty-instead-of-open-coding +++ a/mm/page_alloc.c @@ -3460,8 +3460,7 @@ bool __zone_watermark_ok(struct zone *z, return true; } #endif - if (alloc_harder && - !list_empty(&area->free_list[MIGRATE_HIGHATOMIC])) + if (alloc_harder && !free_area_empty(area, MIGRATE_HIGHATOMIC)) return true; } return false; _ Patches currently in -mm which might be from chenqiwu@xxxxxxxxxx are mm-memory_hotplug-use-__pfn_to_section-instead-of-open-coding.patch mm-fix-ambiguous-comments-for-better-code-readability.patch lib-rbtree-fix-coding-style-of-assignments.patch