The patch titled Subject: mm/memory_hotplug.c: use __pfn_to_section() instead of open-coding has been added to the -mm tree. Its filename is mm-memory_hotplug-use-__pfn_to_section-instead-of-open-coding.patch This patch should soon appear at http://ozlabs.org/~akpm/mmots/broken-out/mm-memory_hotplug-use-__pfn_to_section-instead-of-open-coding.patch and later at http://ozlabs.org/~akpm/mmotm/broken-out/mm-memory_hotplug-use-__pfn_to_section-instead-of-open-coding.patch Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next and is updated there every 3-4 working days ------------------------------------------------------ From: chenqiwu <chenqiwu@xxxxxxxxxx> Subject: mm/memory_hotplug.c: use __pfn_to_section() instead of open-coding Use __pfn_to_section() API instead of open-coding for better code readability. Link: http://lkml.kernel.org/r/1584345134-16671-1-git-send-email-qiwuchen55@xxxxxxxxx Signed-off-by: chenqiwu <chenqiwu@xxxxxxxxxx> Acked-by: David Hildenbrand <david@xxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/memory_hotplug.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) --- a/mm/memory_hotplug.c~mm-memory_hotplug-use-__pfn_to_section-instead-of-open-coding +++ a/mm/memory_hotplug.c @@ -495,7 +495,7 @@ static void __remove_section(unsigned lo unsigned long map_offset, struct vmem_altmap *altmap) { - struct mem_section *ms = __nr_to_section(pfn_to_section_nr(pfn)); + struct mem_section *ms = __pfn_to_section(pfn); if (WARN_ON_ONCE(!valid_section(ms))) return; _ Patches currently in -mm which might be from chenqiwu@xxxxxxxxxx are mm-slubc-replace-cpu_slab-partial-with-wrapped-apis.patch mm-slubc-replace-kmem_cache-cpu_partial-with-wrapped-apis.patch mm-page_alloc-use-free_area_empty-instead-of-open-coding.patch mm-page_alloc-simplify-page_is_buddy-for-better-code-readability.patch mm-memory_hotplug-use-__pfn_to_section-instead-of-open-coding.patch mm-fix-ambiguous-comments-for-better-code-readability.patch lib-rbtree-fix-coding-style-of-assignments.patch