The patch titled Subject: mm/sparse.c: use macros instead of open-coding has been removed from the -mm tree. Its filename was mm-sparsemem-use-wrapped-macros-instead-of-open-coding.patch This patch was dropped because it had testing failures ------------------------------------------------------ From: chenqiwu <chenqiwu@xxxxxxxxxx> Subject: mm/sparse.c: use macros instead of open-coding Use macros instead of open-coding for better code readability. Link: http://lkml.kernel.org/r/1583489966-16390-1-git-send-email-qiwuchen55@xxxxxxxxx Signed-off-by: chenqiwu <chenqiwu@xxxxxxxxxx> Reviewed-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/sparse.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) --- a/mm/sparse.c~mm-sparsemem-use-wrapped-macros-instead-of-open-coding +++ a/mm/sparse.c @@ -385,8 +385,8 @@ static void __init check_usemap_section_ old_pgdat_snr = NR_MEM_SECTIONS; } - usemap_snr = pfn_to_section_nr(__pa(usage) >> PAGE_SHIFT); - pgdat_snr = pfn_to_section_nr(__pa(pgdat) >> PAGE_SHIFT); + usemap_snr = pfn_to_section_nr(virt_to_pfn(usage)); + pgdat_snr = pfn_to_section_nr(virt_to_pfn(pgdat)); if (usemap_snr == pgdat_snr) return; @@ -677,7 +677,7 @@ struct page * __meminit populate_section return NULL; got_map_page: - ret = (struct page *)pfn_to_kaddr(page_to_pfn(page)); + ret = (struct page *)page_to_virt(page); got_map_ptr: return ret; _ Patches currently in -mm which might be from chenqiwu@xxxxxxxxxx are mm-slubc-replace-cpu_slab-partial-with-wrapped-apis.patch mm-slubc-replace-kmem_cache-cpu_partial-with-wrapped-apis.patch mm-page_alloc-use-free_area_empty-instead-of-open-coding.patch mm-fix-ambiguous-comments-for-better-code-readability.patch lib-rbtree-fix-coding-style-of-assignments.patch