The patch titled Subject: mm/memory-failure.c: use page_shift() in add_to_kill() has been removed from the -mm tree. Its filename was mm-memory-failurec-replace-with-page_shift-in-add_to_kill.patch This patch was dropped because it was merged into mainline or a subsystem tree ------------------------------------------------------ From: Yunfeng Ye <yeyunfeng@xxxxxxxxxx> Subject: mm/memory-failure.c: use page_shift() in add_to_kill() page_shift() is supported after the commit 94ad9338109f ("mm: introduce page_shift()"). So replace with page_shift() in add_to_kill() for readability. Link: http://lkml.kernel.org/r/543d8bc9-f2e7-3023-7c35-2e7ed67c0e82@xxxxxxxxxx Signed-off-by: Yunfeng Ye <yeyunfeng@xxxxxxxxxx> Reviewed-by: David Hildenbrand <david@xxxxxxxxxx> Acked-by: Naoya Horiguchi <n-horiguchi@xxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/memory-failure.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) --- a/mm/memory-failure.c~mm-memory-failurec-replace-with-page_shift-in-add_to_kill +++ a/mm/memory-failure.c @@ -320,7 +320,7 @@ static void add_to_kill(struct task_stru if (is_zone_device_page(p)) tk->size_shift = dev_pagemap_mapping_shift(p, vma); else - tk->size_shift = compound_order(compound_head(p)) + PAGE_SHIFT; + tk->size_shift = page_shift(compound_head(p)); /* * Send SIGKILL if "tk->addr == -EFAULT". Also, as _ Patches currently in -mm which might be from yeyunfeng@xxxxxxxxxx are