The patch titled Subject: lib/plist: rename DEBUG_PI_LIST to DEBUG_PLIST has been added to the -mm tree. Its filename is lib-plist-rename-debug_pi_list-to-debug_plist.patch This patch should soon appear at http://ozlabs.org/~akpm/mmots/broken-out/lib-plist-rename-debug_pi_list-to-debug_plist.patch and later at http://ozlabs.org/~akpm/mmotm/broken-out/lib-plist-rename-debug_pi_list-to-debug_plist.patch Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next and is updated there every 3-4 working days ------------------------------------------------------ From: Davidlohr Bueso <dave@xxxxxxxxxxxx> Subject: lib/plist: rename DEBUG_PI_LIST to DEBUG_PLIST This is a lot more appropriate than PI_LIST, which in the kernel one would assume that it has to do with priority-inheritance; which is not -- furthermore futexes make use of plists so this can be even more confusing, albeit the debug nature of the config option. Link: http://lkml.kernel.org/r/20190317185434.1626-1-dave@xxxxxxxxxxxx Signed-off-by: Davidlohr Bueso <dbueso@xxxxxxx> Reviewed-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- include/linux/plist.h | 4 ++-- lib/Kconfig.debug | 2 +- lib/plist.c | 4 ++-- 3 files changed, 5 insertions(+), 5 deletions(-) --- a/include/linux/plist.h~lib-plist-rename-debug_pi_list-to-debug_plist +++ a/include/linux/plist.h @@ -231,7 +231,7 @@ static inline int plist_node_empty(const * @type: the type of the struct this is embedded in * @member: the name of the list_head within the struct */ -#ifdef CONFIG_DEBUG_PI_LIST +#ifdef CONFIG_DEBUG_PLIST # define plist_first_entry(head, type, member) \ ({ \ WARN_ON(plist_head_empty(head)); \ @@ -248,7 +248,7 @@ static inline int plist_node_empty(const * @type: the type of the struct this is embedded in * @member: the name of the list_head within the struct */ -#ifdef CONFIG_DEBUG_PI_LIST +#ifdef CONFIG_DEBUG_PLIST # define plist_last_entry(head, type, member) \ ({ \ WARN_ON(plist_head_empty(head)); \ --- a/lib/Kconfig.debug~lib-plist-rename-debug_pi_list-to-debug_plist +++ a/lib/Kconfig.debug @@ -1350,7 +1350,7 @@ config DEBUG_LIST If unsure, say N. -config DEBUG_PI_LIST +config DEBUG_PLIST bool "Debug priority linked list manipulation" depends on DEBUG_KERNEL help --- a/lib/plist.c~lib-plist-rename-debug_pi_list-to-debug_plist +++ a/lib/plist.c @@ -26,7 +26,7 @@ #include <linux/bug.h> #include <linux/plist.h> -#ifdef CONFIG_DEBUG_PI_LIST +#ifdef CONFIG_DEBUG_PLIST static struct plist_head test_head; @@ -173,7 +173,7 @@ void plist_requeue(struct plist_node *no plist_check_head(head); } -#ifdef CONFIG_DEBUG_PI_LIST +#ifdef CONFIG_DEBUG_PLIST #include <linux/sched.h> #include <linux/sched/clock.h> #include <linux/module.h> _ Patches currently in -mm which might be from dave@xxxxxxxxxxxx are lib-plist-rename-debug_pi_list-to-debug_plist.patch