- some of the rest of MM - various misc things - dynamic-debug updates - checkpatch - some epoll speedups - autofs - rapidio - lib/, lib/lzo/ updates 85 patches, based on f90d64483ebd394958841f67f8794ab203b319a7: Subject: hugetlb: allow to free gigantic pages regardless of the configuration Subject: hugetlbfs: fix potential over/underflow setting node specific nr_hugepages Subject: kernel.h: unconditionally include asm/div64.h for do_div() Subject: kernel/panic.c: taint: fix debugfs_simple_attr.cocci warnings Subject: <linux/kernel.h>: drop the gcc-3.3 'const' hack in roundup() Subject: include/linux/types.h: use "unsigned int" instead of "unsigned" Subject: kernel/hung_task.c - fix sparse warnings Subject: kernel/hung_task.c: Use continuously blocked time when reporting. Subject: kernel/sys: annotate implicit fall through Subject: scripts/spelling.txt: add more spellings to spelling.txt Subject: build_bug.h: add wrapper for _Static_assert Subject: lib/vsprintf.c: move sizeof(struct printf_spec) next to its definition Subject: linux/fs.h: move member alignment check next to definition of struct filename Subject: linux/kernel.h: use 'short' to define USHRT_MAX, SHRT_MAX, SHRT_MIN Subject: linux/kernel.h: split *_MAX and *_MIN macros into <linux/limits.h> Subject: include/linux/pid.h: remove next_pidmap() declaration Subject: linux/device.h: use DYNAMIC_DEBUG_BRANCH in dev_dbg_ratelimited Subject: linux/net.h: use DYNAMIC_DEBUG_BRANCH in net_dbg_ratelimited Subject: linux/printk.h: use DYNAMIC_DEBUG_BRANCH in pr_debug_ratelimited Subject: dynamic_debug: consolidate DEFINE_DYNAMIC_DEBUG_METADATA definitions Subject: dynamic_debug: don't duplicate modname in ddebug_add_module Subject: dynamic_debug: use pointer comparison in ddebug_remove_module Subject: dynamic_debug: remove unused EXPORT_SYMBOLs Subject: dynamic_debug: move pr_err from module.c to ddebug_add_module Subject: dynamic_debug: add static inline stub for ddebug_add_module Subject: dynamic_debug: refactor dynamic_pr_debug and friends Subject: btrfs: implement btrfs_debug* in terms of helper macro Subject: ACPI: use proper DYNAMIC_DEBUG_BRANCH macro Subject: ACPI: remove unused __acpi_handle_debug macro Subject: ACPI: implement acpi_handle_debug in terms of _dynamic_func_call Subject: include/linux/bitops.h: set_mask_bits() to return old value Subject: lib/div64.c: off by one in shift Subject: lib/test_ubsan.c: VLA no longer used in kernel Subject: lib/assoc_array.c: mark expected switch fall-through Subject: lib/test_firmware.c: remove some dead code Subject: checkpatch: verify SPDX comment style Subject: checkpatch: add some new alloc functions to various tests Subject: checkpatch: allow reporting C99 style comments Subject: checkpatch: add test for SPDX-License-Identifier on wrong line # Subject: epoll: make sure all elements in ready list are in FIFO order Subject: epoll: unify awaking of wakeup source on ep_poll_callback() path Subject: epoll: use rwlock in order to reduce ep_poll_callback() contention Subject: fs/binfmt_elf.c: don't be afraid of overflow Subject: fs/binfmt_elf.c: use list_for_each_entry() Subject: fs/binfmt_elf.c: spread const a little Subject: init/calibrate.c: provide proper prototype Subject: autofs: add ignore mount option Subject: fs/autofs/inode.c: use seq_puts() for simple strings in autofs_show_options() Subject: autofs: clear O_NONBLOCK on the pipe Subject: fat: enable .splice_write to support splice on O_DIRECT file Subject: fs/exec.c: replace opencoded set_mask_bits() Subject: exec: increase BINPRM_BUF_SIZE to 256 Subject: kernel: workqueue: clarify wq_worker_last_func() caller requirements Subject: drivers/rapidio/rio_cm.c: fix potential oops in riocm_ch_listen() Subject: rapidio/mport_cdev: mark expected switch fall-through Subject: sysctl: handle overflow in proc_get_long Subject: sysctl: handle overflow for file-max Subject: kernel/gcov/gcc_3_4.c: use struct_size() in kzalloc() Subject: configs: get rid of obsolete CONFIG_ENABLE_WARN_DEPRECATED Subject: kernel/configs: use .incbin directive to embed config_data.gz Subject: kcov: no need to check return value of debugfs_create functions Subject: kcov: convert kcov.refcount to refcount_t Subject: scripts/gdb: replace flags (MS_xyz -> SB_xyz) Subject: lib/ubsan: default UBSAN_ALIGNMENT to not set Subject: init/initramfs.c: provide more details in error messages Subject: ipc: annotate implicit fall through Subject: ipc/sem.c: replace kvmalloc/memset with kvzalloc and use struct_size Subject: lib/lzo: tidy-up ifdefs Subject: lib/lzo: 64-bit CTZ on arm64 Subject: lib/lzo: fast 8-byte copy on arm64 Subject: lib/lzo: implement run-length encoding Subject: lib/lzo: separate lzo-rle from lzo Subject: powerpc: prefer memblock APIs returning virtual address Subject: microblaze: prefer memblock API returning virtual address Subject: sh: prefer memblock APIs returning virtual address Subject: openrisc: simplify pte_alloc_one_kernel() Subject: arch: simplify several early memory allocations Subject: arm, s390, unicore32: remove oneliner wrappers for memblock_alloc() Subject: mm: create the new vm_fault_t type Subject: MAINTAINERS: fix GTA02 entry and mark as orphan Subject: unicore32: stop printing the virtual memory layout Subject: arch/nios2/mm/fault.c: remove duplicate include Subject: include/linux/relay.h: fix percpu annotation in struct rchan Subject: kernel/fork.c: remove duplicated include Subject: samples/mic/mpssd/mpssd.h: remove duplicate header