The patch titled Subject: mm/swapfile.c: use struct_size() in kvzalloc() has been added to the -mm tree. Its filename is mm-swapfilec-use-struct_size-in-kvzalloc.patch This patch should soon appear at http://ozlabs.org/~akpm/mmots/broken-out/mm-swapfilec-use-struct_size-in-kvzalloc.patch and later at http://ozlabs.org/~akpm/mmotm/broken-out/mm-swapfilec-use-struct_size-in-kvzalloc.patch Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next and is updated there every 3-4 working days ------------------------------------------------------ From: "Gustavo A. R. Silva" <gustavo@xxxxxxxxxxxxxx> Subject: mm/swapfile.c: use struct_size() in kvzalloc() One of the more common cases of allocation size calculations is finding the size of a structure that has a zero-sized array at the end, along with memory for some number of elements for that array. For example: struct foo { int stuff; struct boo entry[]; }; size = sizeof(struct foo) + count * sizeof(struct boo); instance = kvzalloc(size, GFP_KERNEL); Instead of leaving these open-coded and prone to type mistakes, we can now use the new struct_size() helper: instance = kvzalloc(struct_size(instance, entry, count), GFP_KERNEL); Notice that, in this case, variable size is not necessary, hence it is removed. This code was detected with the help of Coccinelle. Link: http://lkml.kernel.org/r/20190221154622.GA19599@embeddedor Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx> Reviewed-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- --- a/mm/swapfile.c~mm-swapfilec-use-struct_size-in-kvzalloc +++ a/mm/swapfile.c @@ -2713,9 +2713,8 @@ static struct swap_info_struct *alloc_sw struct swap_info_struct *p; unsigned int type; int i; - unsigned int size = sizeof(*p) + nr_node_ids * sizeof(struct plist_node); - p = kvzalloc(size, GFP_KERNEL); + p = kvzalloc(struct_size(p, avail_lists, nr_node_ids), GFP_KERNEL); if (!p) return ERR_PTR(-ENOMEM); _ Patches currently in -mm which might be from gustavo@xxxxxxxxxxxxxx are ocfs2-use-zero-sized-array-and-struct_size-in-kzalloc.patch mm-memcontrol-use-struct_size-in-kmalloc.patch mm-swapfilec-use-struct_size-in-kvzalloc.patch assoc_array-mark-expected-switch-fall-through.patch gcov-use-struct_size-in-kzalloc.patch ipc-semc-replace-kvmalloc-memset-with-kvzalloc-and-use-struct_size.patch